Skip to Content
avatar image
Former Member

alv

In Interactive alv display when I click a particular field in the first alv it is taking me to the second one.In the second alv display I have for a particular notification no. in the first alv display I have more than 1 record for a single not. no. In that case if there is more than one record the first record will be displayed as it is but in the second record the not. no field alone should not appear.The other details shoul appear.How to achieve this?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 20, 2007 at 05:39 AM

    HI,

    you have to use the sort functionality in the second alv

    use

    this

    data:

    GWA_SORT TYPE SLIS_SORTINFO_ALV,

    GIT_SORT TYPE SLIS_T_SORTINFO_ALV.

    GWA_SORT-SPOS = 1. " Sort order

    GWA_SORT-FIELDNAME = 'LIFNR'.

    GWA_SORT-TABNAME = 'GIT_NOTPOST'.

    GWA_SORT-UP = 'X'.

    • x_sort-subtot = 'X'. " Sub total allowed

    APPEND GWA_SORT TO GIT_SORT.

    CLEAR GWA_SORT.

    CALL FUNCTION 'REUSE_ALV_GRID_DISPLAY'

    IT_SORT = git_sort

    then it will work..

    thanks & regards,

    Venkatesh

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2007 at 05:45 AM

    HI,

    u need to fill the internal table which u r showing in th alv as the format u want to be appear.

    rgds,

    bharat.

    Add comment
    10|10000 characters needed characters exceeded