Skip to Content
author's profile photo
Former Member

Error: Restrict variable to single value

Hi experts,

for key figure planning, I created a planning profile group, which contains 3 planning profiles. But when choosing the Planing Profile Group, I get the error message as follows:

Error: Restrict variable 4MKTHI01 () (area 4CRM0001 (CRM Marketing Plan Values)) to single value

How can I fix the error? I appreciate any kind of help!

Thanks in advance,

Thorsten

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    author's profile photo
    Former Member
    Posted on Aug 20, 2007 at 03:47 AM

    Hi,

    It seemed like you have more than 1 version selected for the plan variable? You'd have to select only 1 value for the variable 4MKTHI01.

    Hope this helps.

    Cheers,

    Gimmo

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Gimmo,

      thx for the fast reply!

      But where can I restrict the value for the variable 4MKTHI01?

      In the BPS0, under "Set Variables", under "Set and Edit Selections" for the Variable 4MKTHI01, I cannot do any settings (user rights SAP_ALL).

  • author's profile photo
    Former Member
    Posted on Aug 20, 2007 at 04:14 AM

    If you intend to use a char in the header and if you dont use a variable, then then you will get such messages.

    Go to the planiogn area and go to the variable and restrict the value to single values.

    Ravi Thothadri

    Add comment
    10|10000 characters needed characters exceeded

  • author's profile photo
    Former Member
    Posted on Aug 20, 2007 at 05:10 AM

    Go to the variable and click change.

    On the right side of the screen, you will see the place to define the values. Chose your values and save the area.

    Ravi Thothadri

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi,

      I think the variable you are trying to restrict is not created correctly. Go to planning area in change mode, edit the variable and mark it to be restricted by user. Now you should be able to restrict it to single value.

      Let me know if that helps.