Skip to Content
avatar image
Former Member

Forecast: Moving Average (Variable)

Hi Everybody!

I'm working on a forecast planning and I have a problem with the standar "Moving Average" formula.

I have a multiprovider that contains the plan and the real provider, in the real, a year of history is loaded, I have a planning secuence in which two functions are called: 1) a copy function for copying the historic data to the plan cube, and 2) the forecast function (moving average) with the following parameters:

- Forecast Period: the variable 0FISCPER, with these, the final user indicate the period he wants to plan

- Past Period: the variable 0FISCPER - 12

- Historic Data Filter: empty

- Historic Key Figure: ZNETWGBIL the key figure that is gonna be changed by the function

- Forecast Strategy: Media Variable

- Order: 3

It executes the copying function correctly, but it doesn't do ANYTHING for the forecast function. If change just the Forecast Strategy to "average" or any other, it do it correctly and in the plan cube the records of the copy and the ones for the forecast whit the key figure changed appropriately are created.

The problem is that I need to user Moving Average.

I'll really apreciate any help.

Thnks in advance.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Aug 23, 2007 at 08:50 PM

    Hi,

    I would analyse the execution with trace in the planning modeler and find out what the system gives as reference data, ... If you really have nothing in here, check your filter and all your characteristics step by step. Start with a simple dataset. 9 times on 10 that will solve your case.

    D

    Add comment
    10|10000 characters needed characters exceeded