Skip to Content
avatar image
Former Member

Comma is showing at the place of decimal(.)

Dear Gurus,

In sap script at the place of decimal in netweigh and currency fields comma coming.

Please tell me how i can show the decimal.Its very urgent.

Thanks in advance.

Regards

Maqsood.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 19, 2007 at 07:25 AM

    Well from there it is handled but i dont know why ur not getting the right out. here is my email address usman.malik.sap@gmail.com Mail me the screen shot of ur DEFAULTS in own setting and i can tell u exactly what to do.

    Regards,

    Muhammad Usman

    Add comment
    10|10000 characters needed characters exceeded

    • There are many possibilities for displaying "," in place of decimal.. it may be because of base curreny or country etc... but if you want "," to be displayed always do it like this..

      EX:

      write t_menge to t_menge right-justified.

      if t_menge+13(1) = ','.

      t_menge+13(1) = '.'.

      endif.

      Close the thread if youe question is answered.

      Regards,

      SaiRam

  • avatar image
    Former Member
    Aug 19, 2007 at 06:52 AM

    its Easy Maqsood bhai,

    go into Utilities------> OWN DATA and there in Defaults. Here u can identify ur Decimal Settings.

    Regards,

    Muhammad Usman

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 19, 2007 at 07:15 AM

    Well go in SMARTFORMS and from there in SYSTEM -


    > USER PROFILE -


    > OWN DATA and in this DEFAULTS and the FIELD is DECIMAL NOTATION. Here as u can see there u can make Decimal as ',' or '.' or even ' '.

    Regards,

    Muhammad Usman

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 19, 2007 at 07:22 AM

    Hi ,

    If nothing is working then try :

    replace statement .

    Regards

    Add comment
    10|10000 characters needed characters exceeded