Skip to Content

HTML Sytntax Error Debugging

Hello,

I am getting an error in Internet Explorer when I use the Account Assignment help screen. It is after I make a selection from the help screen that the shopping cart goes through some processing and the yellow triangle icon at bottom left appears. The message says "Done, but with errors on page'.

I double click the icon and the popup incidates a 3 differetn syntax errors on line(s) 2451,3638 & 4792 char 32 with a same huge URL. I did a view source with notepad++ but I do not think it is the same web page since those line numbers are blank lines or something else and that the shopping cart kicks me out the of cist assignment section.

How can I debug this?

Message was edited by:

Dean Hinson

Actually is does nt kick me out of the account assignment section. Sorry about that but this is the URL listed in the error message from interet explorer...

https://ourserver.com/sap(cz1TSUQlM2FBTk9OJTNhcmIzZGRlYjFfREVCXzAwJTNhWHJ1SElHM0xYRGtDa1NldXhiUjE0dFJjbG5SbkphQXJWVk44RGVqei1BVFQflNUQVRFPTI4MDU1LjAyMC4wNi40MQ==?control[1]=18.139&searchhelpfield[1]=t_screen_acclist-acc_cat%5b1%5d&event[1]=ResultTableSelect&row[1]=6&m_id[1]=18.139&column[1]=SP&description[1]=Z-Statistical+Project&hold[1]=0&destination[1]=1&~responsetype[1]=dynpro&g_flag_update[1]=X

Message was edited by:

Dean Hinson

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 19, 2007 at 05:08 PM

    Hi

    Which SRM version are you using ?

    <u>Seems like either your Internet Explorer and Java Run time environment (JRE version) are not installed properly in the PC.. Please re-install IE version 6 from microsoft website and/or above and JRE 1.5 Version from Sun microsystems website...</u>

    <b>Also check, what Security settings are there in the Internet explorer..

    Tools -> Internet Options

    check in Security and Privacy Tab..</b>

    Hope this will definitely help.

    Do let me know.

    Regards

    - Atul

    Add comment
    10|10000 characters needed characters exceeded

    • Atul,

      Sorry for not getting back to you sooner. But this is happening on all of the computers that I have spot checked, so I do not think it is an JRE or IE problem.

      I implemented some OSS notes regarding Web Template issues and use BADI_UI_CONTROL_BADI to augment some screen behavior. So I am trying to find out if it is the OSS notes, the BADI or a combination. Is there a tool where I can take the generate web page source and have a program check syntax, etc?

      There has to be a way to find what is causing the error.

  • Dec 11, 2007 at 01:56 PM

    This was resolved with an ITS kernel upgrade.

    Add comment
    10|10000 characters needed characters exceeded