Skip to Content
avatar image
Former Member

product catalog from PM - component list not populated

Hi! We have set up catalog calls from both MM and PM (ECC 6.0). From MM everything works OK, but from PM we enter an external catalog and try to order items. The ordered items are however not populated in the component overview, and no error message whatsoever is shown.

We have debugged and notice that items are transferred from catalog, but at some point the data is cleared. The HTML-SAP-field mapping looks like this (txn: ioci_fconv):

RIHFCOM-MEINH NEW_ITEM-UNIT 1 HTML-felt

RIHFCOM-KTEXT NEW_ITEM-DESCRIPTION 1 HTML-felt

RIHFCOM-PREIS NEW_ITEM-PRICE 1 HTML-felt

RIHFCOM-MEINH NEW_ITEM-UNIT 1 HTML-felt

RIHFCOM-MATKL NEW_ITEM-MATGROUP 1 HTML-felt

RIHFCOM-WAERS NEW_ITEM-CURRENCY 1 HTML-felt

________________________________________ ________________________________________ _

Does this look correct (we do not use material numbers). ? Any ideas what might be wrong if the field-mapping is correct?

brgs dag s larsen

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    Aug 17, 2007 at 12:41 PM

    Hi,

    In the component area, there is no material group, neither currency.

    If you try to transfer matnr and quantity only, it should work 😊

    Kind regards,

    Yann

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 17, 2007 at 11:46 AM

    just noticed that I missed NEW_ITEM-QUANTITY (RIHFCOM-MENGE), but it did not make any difference. ds

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 17, 2007 at 01:21 PM

    Thank you Yann - problem solved - the _XL was the issue (wrong structure). One more thing though:

    - we open the catalog within the SAPGUI, but when ordering items, two browser-windows are opened. One blank, one with the bugseye logon-screen (session time out).

    I have been trough all? sdn- and oss-notes regarding this, but do not find anything that helps. Could it be something in the BugsEye - "look&feel", templates etc. ?Any ideas?

    brgs dag s

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      1- What call structure content do you have ?

      2- Which sapgui version are you using ?

      The 640 is perfect but the 710 have a lot of bugs while dealing with http protocol :(((

      if you can test it on a 640 sapgui PC, it would be good.

      Kind regards,

      Yann

  • avatar image
    Former Member
    Aug 20, 2007 at 08:26 AM

    Hi Yann! We run on 640 (fortunately 😊)

    Attached is the call structure we are currently testing - any hints to solve this issue would be appreciated! Brgs dag sigurd

    2 http://hk-sap-61.comp.name 0

    3 corp.com:55400/BugsEye/BugsEye 0

    10 username ole 2

    20 password ole 2

    30 language no-NO 2

    35 config sapcomb 2

    40 HOOK_URL 4

    50 ~OkCode ADDI 2

    60 ~Target _parent 2

    70 ~Caller CTLG 2

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 20, 2007 at 11:10 AM

    Hi Yann! For some reason, the detail (ctrlshiftF2) screen for PM/PS-catalogs are disabled? Works for MM-catalogs ... Any ideas?

    brgs dag S

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2007 at 09:45 AM

    Hi Yann. Is it possible to make the catalog-call in a new browser instead of inframe? If so - do you know how to?

    brgs dag s

    Add comment
    10|10000 characters needed characters exceeded