Skip to Content
avatar image
Former Member

Exchange rate transfer via Flat File

Hi Gurus!

We are trying to import exchange rates via a flat file upload to the table TCURR and gone trough help.sap.com and found that the way to do this is, by right clicking the source system and choosing "Transfer Exchange Rates", the only problem is that the "File" source systems do not have this option. (The SAP source system does have this option, but we cannot apply changes to the SAP source system).

We've tried running the program (RSIMPCURR) manually, but we can't assign a source system then... and creating a variant by right clicking the source system and choosing "Transfer Exchange Rates" isn't an option, because "Transfer Exchange Rates" isn't there...

Please let me know what you think could help us out!

Best Regards,

Bastiaan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 17, 2007 at 03:17 PM

    Hi,

    Please check if the non appearance of 'Transfer Exchange Rates' for PC Files is authorisation related. File source systems do have this option in the context menu if you have the authorisation.

    Hope this helps.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Joachim!

      This answered my question..

      I can use this T-code to load exchange rates with a flat file!!

      For those with the same problem:

      The program ran by this T-code = "RSIMPCURFILE"

      Thanx a million!

      Regards,

      Bastiaan

  • avatar image
    Former Member
    Aug 17, 2007 at 12:31 PM

    Hi Bastian,

    What is your source system?

    You can still copy the abap program RSIMPCURR and adapt your copy in order to load a flat file.

    Regards

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Laurent!

      Thanx for the fast reply ...

      The source system I'm using is: File -> PC_FILE

      Tried it -> made the "source system" field manually selectable, but now when I select the source system "PC_FILE" it terminates in a short dump...

      Any other suggestions

      Regards,

      Bastiaan

      Message was edited by:

      B. Trumpi