Skip to Content
0

SAP Work Manager android client date format

Oct 10, 2016 at 01:51 PM

97

avatar image

Hi All,

We are busy implementing SAP Work Manager 6.2.1 and the client has requested that we should change the date format that is currently displaying as mm/dd/yyyy to display dd/mm/yyyy. Now as far as I understood the format was that the android client reads the system time format, but in my case it does not even though my system time is correct the app still displays the for mat incorrect. has anybody come across a similar issue or fixed the issue?

Regards,

CJ Bester

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Stephen Streeter Oct 12, 2016 at 06:43 PM
0

Can you use an update rule on the display field (or check to see if there is one already)

You would want to something line:
Date

- <Object field>
- d={dd/mm/yyyy}

http://help.sap.com/saphelp_smp305sdk/helpdata/en/7c/1705f970061014b94a962bb56c29a0/content.htm

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Stephen,

I had this rule but it did not work for me, until I changed my date display fields to Strings.

Thanks again for your assistance.

Regards,

CJ Bester

0
Chung Yu
Oct 13, 2016 at 10:33 PM
0

Also, try to change the region setting of the device to see if it helps on display of the time format.

,

Also, If the time field is based getting from the device and not getting from the backend, try changing the region setting on the device to see if it able to display the format you like.

Chung Yu

Share
10 |10000 characters needed characters left characters exceeded
Subash Narayan
Oct 14, 2016 at 03:19 PM
0

Hi CJ,

Setting regional time zones is available in settings page on some of Android devices. Please see the example of the Samsung Galaxy tab in the screen shot.

Thanks

Subash Narayan

SAP Support Engineer


Share
10 |10000 characters needed characters left characters exceeded