Skip to Content
0

Changes done in development system are not reflecting in dev system, but are importing to quality

Aug 14, 2017 at 09:21 AM

40

avatar image

Hi Experts,

I am working on NWDS 7.3 and made some changes in the landing page of my portal. But I am unable to see the changes in the develpoment sytem. I imported the changes to quality systema nd able to see changes there. We are using NWDI for deployment. Also we restarted the system for clearing caches....

What could be the problem...please guide me

Thanks,

Aswini

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

avatar image
Former Member Aug 14, 2017 at 09:39 AM
0

Hi,

Is that JSP Page change? If so, check below regarding Production Mode.

Enabling the Production Mode

In production mode, a change in the JSP page on the file system of the portal does not cause the JSP to be recompiled. For performance reasons, the page recompiles, if necessary, only when the application containing the page is redeployed.

During development and testing, it may be easier to make changes to a JSP on the file system than to make changes in the SAP NetWeaver Developer Studio and then redeploy the application. Therefore, in development mode, the JSP page is checked to see if it was modified each time the page is called.

Procedure

Use SAP NetWeaver Administrator to complete this task:

1. To modify the properties of the Web Container Service using SAP NetWeaver Administrator, use the Java System Properties function.

2. In the Services tab, select Web Container Service.

On the Extended Detailstab page, a list of all service properties is displayed.

3. Find the ProductionMode property in the list of properties and set its value to true.

When set to true, if a class file is already generated for the JSP file, this class is used no matter if the JSP file is modified.

4. Choose Save.

Also did you try deploying it directly to Portal via NWDS instead of NWDI?

Regards,

Madhu

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Forgot to mention. Change the value of ProductionMode property to false and check.

Regards,

Madhu

0

Hi Madhu,

I changed the parameter to false and saved it. Still the changes are not getting reflected. Is there anything to do.. I didn't re-deployed it..since I didn't make any changes. Also I cannot directly deploy it in portal and can do through NWDI only as I am using this for biller direct application.

Please guide me.

Thank you,

Aswini

0
Former Member
Aswini Yagati

Deploy some dummy activity now, since you have changed the parameter and see if that works.

Regards,

Madhu

0