Skip to Content
avatar image
Former Member

CrystalReportViewer don’t show my report

hi

I am using “CrystalReportViewer” in asp.net web form. I am adding belowe code in my project:

C:\inetpub\wwwroot\aspnet_client\system_web\4_0_30319

<%@RegisterAssembly="CrystalDecisions.Web, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304"Namespace="CrystalDecisions.Web"TagPrefix="CR"%>

<sectionGroupname="businessObjects">

<sectionGroupname="crystalReports">

<sectionname="rptBuildProvider"type="CrystalDecisions.Shared.RptBuildProviderHandler, CrystalDecisions.Shared, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304, Custom=null" />

<sectionname="crystalReportViewer"type="System.Configuration.NameValueSectionHandler" />

</sectionGroup>

</sectionGroup>

<businessObjects>

<crystalReports>

<rptBuildProvider>

<addembedRptInResource="true" />

</rptBuildProvider>

<crystalReportViewer>

<addkey="UseBrowserLocale"value="true"/>

<!--<add key="ResourceUri" value="~/crystalreportviewers13" />-->

<addkey="resourceURI"value="~/aspnet_client/system_web/4_0_30319/crystalreportviewers13" />

</crystalReportViewer>

</crystalReports>

</businessObjects>

When I am run my project, “CrystalReportViewer” show my report just for first time.

Please help me why “CrystalReportViewer” don’t show my report for other time?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Aug 15, 2017 at 07:25 PM

    You need to move your code to the Page_Init section, use Sessions and Postback to keep the report in scope.

    Try searching first, this has been answered already.

    Don

    Add comment
    10|10000 characters needed characters exceeded