Skip to Content
avatar image
Former Member

TMS_BCI_START_SERVICE fails

When I schedule the TMS job (following a system copy of Production into my QA system) using STMS, it runs the first time successfully but cancels every subsequent time. I cannot view the job log, but if I look at the TMS error log, I'm getting a "TMS_BCI_GET_JOBINFO_FAILED"(Program TMS_BCI_START_SERVICE has no selection screens).

Per 398589, I'm using STMS to schedule the job. I'm trying to select "Other Period" and schedule this for 10 minutes, but I HAVE to go to SM37 and change the periodicity, since Other Period won't work (it defaults to a daily job).

Any suggestions? I'm running NW 2004S ECC6.0

Message was edited by:

Michael Gibbs

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 17, 2007 at 06:55 AM

    Hi Michael

    although in STMS you will find that 'Other Period' is grey and defaulted to Daily job, you will be able to select another time period, eg. 15min.

    Agreed: there is no 10 minutes option to select...

    But pls try and select the option 'Every 15 min'. This should work.

    (I also did this on Nw 2004S ECC 6.0)

    best regards,

    Heidi

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      While waiting for SAP to respond to my message (still waiting), I was able to get the STMS jobs to work....I'm not exactly sure how they worked, but I'll keep looking...

      Thanks for the suggestion. I tried setting the job to 15 min, but that failed as well (with the above error).

  • avatar image
    Former Member
    Aug 20, 2007 at 09:12 PM

    Hello Michael,

    This seems simple to me. After system copy you would have probably executed SE06 transaction. That would have led to deletion of TMS RFC destinations. This leads to an inconsistency at times with job control records and then you can get TMS_BCI_GET_JOBINFO_FAILED.

    Better thing in this case is to cancel every single instance of import job and schedule it from the beginning.

    Regards.

    Ruchit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Update: We ended up fixing the problem by simply restarting the DBCI after the jobs were scheduled. Something was "out of sync" (perhaps the job control records), but restarting the system seemed to correct the issue.

      Thanks for all suggestions