Skip to Content
0

SAP WEB IDE - Missing Hybrid App Toolkit (HAT) options

Aug 15, 2017 at 01:46 PM

133

avatar image

I've imported a project from SAP BUILD.

For some reason, I can no longer view any additional details in the HAT details in "Project Settings."

All that's there is "Cordova Facade Configuration".

This is a problem as I'd like to include "Offline Mode", or even remove the passcode, which I can't do without the additional settings.

Also, the console is showing the following warning :

"(destination) Destination 'webide_di' is either not a Web IDE destination or not valid because the WebIDEUsage or URL properties are missing in the destination settings.
Check your destination settings in the SAP Cloud Platform Cockpit."

I haven't changed any Cloud Connector setting and all destination connect fine.

Any ideas.?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Jamie Cawley
Aug 17, 2017 at 11:50 AM
1

Assuming you have the HAT plugin enabled, check the project types under the project settings. Make sure mobile is enabled.

Regards,

Jamie

Share
10 |10000 characters needed characters left characters exceeded
Naveen RV Oct 18, 2017 at 09:58 AM
1

Hi Adam,

I hope its not too late,

In .project.json file find projectType property, change to the following

"projectType": 
[
"sap.watt.uitools.ide.fiori",
"com.watt.common.builder.sapui5clientbuild",
"com.sap.webide.hybrid.cordova"
],

This will enable the Hybrid App Configuration in Project Settings.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Great! Thank you!

0
Adam Harkus Aug 23, 2017 at 12:33 PM
0

Mobile isn't there!

Any reason why? My old projects have this enabled, but not my projects imported from SAP Build.

Is there a way to switch on the Mobile functionality for SAP Build Projects ?

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Adam,

I hope its not too late,

In .project.json file find projectType property, change to the following

"projectType": 
[
"sap.watt.uitools.ide.fiori",
"com.watt.common.builder.sapui5clientbuild",
"com.sap.webide.hybrid.cordova"
],

This will enable the Hybrid App Configuration in Project Settings.

0