Skip to Content
avatar image
Former Member

Error while reading ID of own business system from the SLD for system D18

Dear guru's,

I have almost completed a file2proxy scenario but I'm stuk on the following.

When sending a message the outbound adapter says:

<b>Error while reading ID of own business system from the SLD for system D18 and client 200</b>

What's the problem? I'm using a HTTP connection in the comm. channel. In this http connection a user with SAP_ALL is defined.

Any suggestions?

<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>

- <!-- Call Adapter

-->

- http://sap.com/xi/XI/Message/30" xmlns:SOAP=" http://schemas.xmlsoap.org/soap/envelope/" SOAP:mustUnderstand="1">

<SAP:Category>XIServer</SAP:Category>

<SAP:Code area="INTERNAL">SLD_NO_OWN_BS</SAP:Code>

<SAP:P1>D18</SAP:P1>

<SAP:P2>200</SAP:P2>

<SAP:P3 />

<SAP:P4 />

<SAP:AdditionalText />

<SAP:ApplicationFaultMessage namespace="" />

<SAP:Stack>Error while reading ID of own business system from the SLD for system D18 and client 200</SAP:Stack>

<SAP:Retry>M</SAP:Retry>

</SAP:Error>

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 14, 2007 at 02:27 PM

    Hi,

    did you check the following threads:

    error-while-reading-the-id-of-own-business-system

    differents-mandants-in-one-system

    Regards,

    Francesco

    Add comment
    10|10000 characters needed characters exceeded

    • Login to the machine anc check the TC SLDAPICUST there the entries should point correclty to the SLD Server and the user should be PIAPPLSUER.

      Also run the TC SLDCHECK to see you are able to ping to SLD

      This error SLD No Business System found appears only when the connection between the system and SLD is broken. this connection is maintaniend in the SLDAPICUST, once this is done do to ID and referesh the SLD Cache.

      Hope this fixes the problem

  • avatar image
    Former Member
    Aug 14, 2007 at 02:42 PM

    Hi,

    Check out TC SLDAPICUST on application system...you need to maintain XI system details here...

    Nilesh

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 14, 2007 at 02:42 PM

    Login to system D18 and client 200 and check the TC SLDCHECK and also as per my pervious message check the entries in the SLDAPICUST, it should point to the Server on which SLD is present usually XI server https.

    Actually what happens in this error is when you are done with the configuration part in the ID, you are trying to eceute the scenario File to proxy, when it comes to identify the receiver system which is D18 clnt 200, it goes to SLD to check it and SLD is trying to ping to the machine D18 this connection is set from the TC SLDAPICUST on the machine D18.

    here the problem is that either the D18 is not able to ping to the SLD and also try refreshing the SLD cache.

    Hope you problem is fixed

    Add comment
    10|10000 characters needed characters exceeded