Skip to Content

List Report - Object Page not displaying table

Hi all,

I'm creating a List Report (Smart Template) in SAP WebIDE with a custom ODATA service on a back-end Gateway.

So far so good, the first page which is containing the actual list is working fine, including all filters etc. But when I'm navigating to the object page by clicking on a record, I want to show some data in the header, also working fine.

The problem starts when I want to display a table in the second section of the object page, the section is showing, but there is no data:

The table is linked to another Entity Type, which is linked with an assocation set in the ODATA service and in the template selected as Navigation Property:

It looks like there's something wrong for the facets of the object page. Even when I try to change a label or field for the object page, the change doesn't show (also tried deploying)...

I already checked out this blog: https://blogs.sap.com/2016/04/14/how-to-use-smart-templates-with-sap-web-ide-object-page/ but can't find any difference...

Hope you experts have any idea why my table is not shown in the object page, and why changes that I make in the annotations for the object page are not shown. Changes for the list report itself are working fine...

knipsel.png (26.3 kB)
doc1-1.jpg (128.5 kB)
doc1-2.jpg (97.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Nov 24, 2017 at 08:30 AM

    Hi Srikar,

    Yes, the problem was solved. I somehow forgot to update this post and missed your comment, sorry about that... The problem was that I put a reference facet inside a collection facet, there's no need for that. I just put the reference facet directly inside the facets and the problem was solved.

    For your issue (if it's not solved already): When you're clicking on a line item from the list report it tries to navigate to the object page. If there's no object page in place, you'll get a blank page like this.

    Several UI types are used for the object page, so you have to populate at least one of those UI groups as for example the UI.Facets. Just have a look at this blog by SIMMACO FERRIERO. The look and feel of Web IDE changed somewhat overtime, but the blog should be a good starting point for you to configure your object page.

    Good to hear that you're starting on Elements and smart templates! If you have any more questions, let me know!

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 15, 2017 at 09:01 AM

    Little update: I also tried the ES4 gateway service as described in https://blogs.sap.com/2016/04/14/how-to-use-smart-templates-with-sap-web-ide-object-page/

    Same result, still no line items are displayed in the second facet... Getting really curious why this is not working anymore in WebIDE.

    I also put a breakpoint on the backend ABAP code which is called to get the entityset for the line items on the object page. The is called and works fine, it puts all the expected records in the ET_ENTITYSET.... No errors in the /IWNFD/ERROR_LOG either..

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Maximilian,

      Did you Resolve the issue ?

      I am using SAP IDE 1.32 version and I am able to get the list report page but if I click on the Line Item, a blank page is displayed with an error logs in the console saying

      I am able to get the data for List Page.

      But, After Clicking on the Line Item

      In Console.

      How can I get the object page?

      I am new to smart templates. Could you please help me out?