Skip to Content

Error connecting BO 4.2 webi to BW BIP connection; internal Java Treewalker

Problem: While creating query using webi@LaunchPad to BW connection (BIP Platform), the connection explorer gives error.

So far unable to find cause and solution, please help.Seems to DSLbridge related, tried re-starting APS or making new APS for DSL bridge

Error Code -> DSL 00000

Internal SDK function --> DSLBridgeController:doIT

System Info: BO 4.2 SP1 Patch 2, BW 7.5

Other Analysis Info:

Analysis for OLAP web application able to traverse SAME BW connection and info area/info provider/query but after selecting a OLE DB enabled query, gives error

Design Studio version 1.6 easily connects and returns data with this SAME BW connection

I am aware Design Studio uses its on embedded DSL bridge and webi uses separate one. So seems to be webi’s DSL bridge issue.

I ran E2E trace but couldn’t find anything specific as error shows to happen all of the sudden with seemingly no before and after ActionID.

Trace from GLF trace file


1.jpg (44.9 kB)
2.jpg (34.6 kB)
3.jpg (929.3 kB)
4.jpg (189.8 kB)
5.jpg (636.1 kB)
6.jpg (261.3 kB)
7.jpg (226.5 kB)
8.jpg (502.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    Aug 28, 2017 at 01:47 PM

    Resolved after update the BIP to BO 4.2 SP4 patch 2.

    Thank you for your comments

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 13, 2017 at 07:54 PM

    Nitin,

    Need a lot more information to help you troubleshoot, such as:

    - What version of BI 4.x are you running ? Exact build ?

    - How much total memory configured on the server ?

    - Have you used the APS wizard to split the APS properly? What size split choose (small, med, large, . . )?

    - Have you adjusted memory settings within DSLBridge Server to -Xmx6g or better ?

    Regards,

    Ajay

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Ajay,

      Thank you for your attention. Here are the info

      - What version of BI 4.x are you running ? Exact build ?

      Version: 14.2.1.1962

      - How much total memory configured on the server ?

      Approx 16G out of 32G host

      - Have you used the APS wizard to split the APS properly? What size split choose (small, med, large, . . )?

      Earlier it was default APS which was configured with Xmx2G but now (cloned of original APS) DSLBridge specific APS (DSL bridge, security token, webi monitoring services) has Xmx8G, rest other services are kept in one other single APS-Others (clone of original)

      - Have you adjusted memory settings within DSLBridge Server to -Xmx6g or better ?

      Its now DSLBridge specific APS which has Xmx8G.

      Hope to hear back from you, what's your initial guess.

      Regards,

      Nitin

  • Aug 14, 2017 at 02:15 PM

    Sounds like its time to log a support incident with SAP (bi-ra-wbi component).
    If I had to guess - either not enough resources for the DLS brigde and other webi components or connectivity issue from webi machine to BW...

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 26, 2017 at 05:28 PM

    I have de same error with BI4.2 SP4 patch 3.

    the connection works with Analysis for olap, but does not work with WEBI
    i don't find solution

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 26, 2017 at 05:28 PM

    I have de same error with BI4.2 SP4 patch 3.

    the connection works with Analysis for olap, but does not work with WEBI
    i don't find solution

    Add comment
    10|10000 characters needed characters exceeded