Skip to Content
0

Maxdb logon for new installation

Aug 11, 2017 at 01:13 AM

83

avatar image
Former Member

Just installed NW7.5 with Maxdb. Was going through post steps and executing sgen when (I think) my logs filled up and my system hung. Tried to install the Database studio to log in, create a backup and release the logs. However - it's rejecting all of the users that were created with the install (SQD, SQDDD1) with an autorization error. I've also tried everything possible I've seen through the internet (DD1ADM, SAPDD1, control, adm, SUPERADMIN,???)

The installation was through swpm while installation of NW 7.5 on SLES12. Didn't seem to have any issues until 10 minutes after starting sgen. I didn't see any other users come up during the installation??? I will asy that I'm completely new to this (as an ABAPer) and would love to hear that it's a stupid issue on my side.

Someone ask for the following on another thread I was looking at, so here are a couple of commands I ran...

solman:/media/dowloadmanager/dbstudio/maxdb-studio-desktop-linux-64bit-x86_64-7_9_09_05 # sdbregview u2013l
Global /sapdb/programs 7.9.08.23
DatabaseStudio /media/dowloadmanager/dbstudio/maxdb-studio-desktop-linux-64bit-x86_64-7_9_09_05 7.9.09.05
DB1 /sapdb/DB1/db 7.9.08.23
CL_DN1 /sapdb/clients/DN1 7.9.09.05
DD1 /sapdb/DD1/db 7.9.09.05
ERR: Failed
ERR: cannot open installation
solman:/media/dowloadmanager/dbstudio/maxdb-studio-desktop-linux-64bit-x86_64-7_9_09_05 # dbmcli inst_enum
OK
7.9.09.05 /media/dowloadmanager/dbstudio/maxdb-studio-desktop-linux-64bit-x86_64-7_9_09_05
7.9.09.05 /sapdb/DD1/db
7.9.09.05 /sapdb/clients/DN1
7.9.08.23 /sapdb/DB1/db
solman:/media/dowloadmanager/dbstudio/maxdb-studio-desktop-linux-64bit-x86_64-7_9_09_05 # dbmcli db_enum
OK
DD1 /sapdb/DD1/db 7.9.09.05 fast offline
DD1 /sapdb/DD1/db 7.9.09.05 quick offline
DD1 /sapdb/DD1/db 7.9.09.05 slow offline
DD1 /sapdb/DD1/db 7.9.09.05 test offline

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
James Zhang
Aug 11, 2017 at 06:01 AM
0

Hi,

Can you show the error when logging on via database studio?
go to maxdb host and also dbmcli failed?

dbmcli -d <dbsid> -u control,<password> db_state
dbmcli -d <dbsid> -u superdba,<password> db_state


By default, maxdb has two admin users: control, superdba

Best regards,
James

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

control,<password> got me in. control,control did not work though.

Thanks for the help!

0
Prithviraj Rajpurohit Aug 11, 2017 at 09:59 AM
0

Hi Tim,

Did you tried with below credentials..?

Username Password

superdba admin

control control

Regards,

Prithviraj

Share
10 |10000 characters needed characters left characters exceeded
Ralf Wahlen Nov 09, 2017 at 03:26 PM
0

Hi Tim, sorry for that, but do you checked the PAM?

SLES 12 with SP0 or SP1? The inst. process is completly run to the end? Some errors comes up, after inst, the inst runs trough, and then the

problems begin. All steps over the bridge are done? All are marked as green?

Authorzation error could be an group Id error, check the group Id of the users, and check the file system authorizations, set them to 777 maybe.(775)

Ta SGEN completly of all programs? What says the MaxDB data volumes on OS? What says the maxdb logfile? Is it full, then youve got an logfile full situation. maybe its to small!!!

If you generate ABAP load, you need logging on the MaxDB and the logs need set to archive mode, the same as in Oracle DB.

If you are an SAP Customer, open a SAP Call, if it is an Prod System. There are a lot of things to analyse............................

sumdone.png


sumdone.png (23.5 kB)
Share
10 |10000 characters needed characters left characters exceeded