Skip to Content

Correct an abap web service after a system copy

Good morning,

After performing a system copy, I have the following error, after starting the soamanger:

IBC with ID equals to Business Appl ID is not client IBC XXXXXX CLIENT /XXX/200

Can not be repaired

How can I know which web service is concerned?

How can I fix only this web service?


Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

8 Answers

  • Best Answer
    Jan 02 at 11:25 AM

    Hi All,

    to whom trying to avoid SRT_WSP_INITIALIZE_WS_CFG as it will erase existing WS config.

    I found this note and applied it.

    Within there is also another note implementation which is 2584635, creates a report.

    After above steps, in SOAMANAGER consitency check, REPAIR option for inconsistency (which was previous in CAN NOT BE REPAIRED status) appears and you can run it. My problem solved this way, now it is green.



    Add comment
    10|10000 characters needed characters exceeded

    • Good morning Emir,

      Thanks a lot for providing Note 2584635.

      In our case, the repair generates a dump.

      Therefore I have opened an incident with SAP.

      The current status is that repairing a refreshed system is not supported...

      Let's see the final status of SAP.

      Refresh is a common supported practice.

      I do not understand why SAP does want their clients to lose all the configuration they have performed with SOAMANAGER.

      It is a huge waste of time.

      Have a nice day.

  • Aug 10, 2017 at 01:18 PM

    Hi Benoit,

    Please go through sap note #2353589 - Consistency Check for Soamanager point 1.

    "Business Application ID was originally created for system <xxx> client <nnn>": This is the result of a system copy and rename of the copy (clone). Afterwards you have two systems with the same application ID. The usage of the same Business Application ID in different systems is not possible. After cloning a system, the configuration of the cloned system has to be reinitialized.

    One reason, why these inconsistencies can occur, is copying database tables of the Web Service configuration from one system to another system.

    For all the inconsistencies having no repair option it is recommended to initialitze the whole Web Service Configuration by calling SRT_WSP_INITIALIZE_WS_CFG (former version: SRT_ADMIN_SYS_COPY) which is the "cleanup" report after a system copy. Report SRT_WSP_INITIALIZE_WS_CFG can be obtained with SAP Note 2392606.

    Attention: This report removes all Web Service configurations in all clients.



    Add comment
    10|10000 characters needed characters exceeded

  • Aug 11, 2017 at 07:29 AM

    Good morning,

    I have found where this error is coming.

    It is in the IBC definition.

    I am surprised because, I have other refreshed systems where it has been properly converted,

    probably by the bdls.

    I am opening a new thread to avoid to many different discussion on this one:

    Thanks in advance for your help.

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 26, 2017 at 12:23 PM


    I just experienced the same issue after a system copy. Did you have find the root cause of why this happened on one system but not on others?

    Compared to our systems I see one difference in that the one where the system copy was an initial creation (using DB Restore / Recover plus SWPM System Copy) SOAMANAGER works correctely. (This system copy was just a refresh so no reinstallation was done using SWPM.)

    What was the solution to fix this issue? 2392606 following recommendation in 2353589?

    In advance, thanks a lot for your help.

    Best regards,


    Add comment
    10|10000 characters needed characters exceeded

    • 2350085 - Consistency check when soamanager is started

      The note states that the consistency check was added as of NW 7.40, so it is possible that there was already issues in some cases.

      Best regards.

  • avatar image
    Former Member
    Oct 16, 2017 at 02:37 PM

    Hi Frank/Benoit,

    Did you solve this issue. Did you run report-SRT_WSP_INITIALIZE_WS_CFG to solve the issue. I have a similar issue, I found note-2392606 and 2456283 that states to run report-SRT_WSP_INITIALIZE_WS_CFG to solve the issue. But wouldn't that delete all the web services.



    Add comment
    10|10000 characters needed characters exceeded

  • Oct 16, 2017 at 02:43 PM

    Good morning,

    We have run the eport SRT_WSP_INITIALIZE_WS_CFG in a sandbox system.

    It has solved the issue.

    Unfortunately it has also deleted webservices' configuration parts, performed from soamanager.

    Therefore webservices that worked before running the report in the sandbox have stopped working after running the reset report.


    Add comment
    10|10000 characters needed characters exceeded

    • Good afternoon,

      I agree that Prithviraj's answer is very close to mine.

      I wouldn't mind accepting his answer instead of mine.

      As you are a moderator can you accept his answer instead of mine?

      Have a nice day,

  • avatar image
    Former Member
    Feb 15, 2018 at 09:29 PM

    Is there a way to fix system copy inconsistencies without run the report to remove ALL web services definitions? we have more than 400+ WS defined and is a problem run that report.


    Add comment
    10|10000 characters needed characters exceeded

  • Jan 28 at 07:53 AM

    Good morning,

    In our case, to avoid the previous dump, we have run the following command:

    SE38 > SRT_WSP_CCY_CHECK in SE38 then opt for CL_SRT__CCY_BUS_APPL_ID

    It has cleared the inconsistency, as suggested by Emir Hanci

    Have a good day.

    Add comment
    10|10000 characters needed characters exceeded