Skip to Content
0
Aug 10, 2007 at 03:07 PM

Error when activating - "cannot resolve symbol"

22 Views

Hi everybody!

I created a WebDynpro DC referencing some other DC's, one of them containing some generated Enterprise Connector classes.

A local build works fine, the WebDynpro looks and works as expected when deployed to our J2EE server. When I activate the associated activities, all DC except the WebDynpro DC compile o.k., but the WebDynpro compilation throws some "cannot resolve symbol" errors, the symbols being the generated classes from the Enterprise Connector DC.

The Activation Log of this component shows that only one class of this DC is being compiled and packed into the public parts of the DC:

[echo] Starting Java compiler

[javac] Compiling 1 source file to /usr/sap/...somewhere.../classes

[timer] Java compilation finished in 0.375 seconds

[echo] Start XLF conversion

[timer] XLF conversion finished in 0.001 seconds

createPublicParts:

[pppacker] Packing assembly public part 'mvRFCAss'

[pppacker] Packed 0 files for entity mvRFCObjects.util (Java Package/Class, mvRFCObjects/util)

[pppacker] Packed 2 files for entity mvRFCObjects (Java Package/Class, mvRFCObjects)

[pppacker] Packed 2 entities for assembly public part 'mvRFCAss'

[timer] Packing of assembly public part 'mvRFCAss' finished in 0.059 seconds

[pppacker] Packing compilation public part 'mvRFCComp'

[pppacker] Packed 0 files for entity GeschaeftsPartnerRFC_PortType (Java Class/Class, mvRFCObjects)

[pppacker] Packed 0 files for entity Z_Ecm_Input (Java Class/Class, mvRFCObjects)

[pppacker] Packed 0 files for entity Z_Ecm_Output (Java Class/Class, mvRFCObjects)

[pppacker] Packed 0 files for entity Ztgd_EcmType (Java Class/Class, mvRFCObjects)

[pppacker] Packed 0 files for entity Ztgd_EcmType_List (Java Class/Class, mvRFCObjects/util)

[pppacker] Packed 2 files for entity MVTestSapAccess (Java Class/Class, mvRFCObjects)

[pppacker] Packed 6 entities for compilation public part 'mvRFCComp'

[timer] Packing of compilation public part 'mvRFCComp' finished in 0.095 seconds

Any hint on what produces such an error or what information you'd need so say something ?

Thanks!