Skip to Content

Subreport Errors Using Stored Procedure

Aug 09, 2017 at 06:47 PM


avatar image

We have a few reports that have subreports embedded. The main and sub reports are using stored procedures. Our schemas include a prefix for organizational purposes. The procedure call for the first report is passed as a parameter and executes properly, the procedure name is in the format Prefix.MainTable. The procedure for the sub report is Prefix.SubTable. The subreport table is listed as SubTable in the Datasource window in the designer with an owner of Prefix. If I run this report in our VB6/COM (Crystal 11) viewer it runs properly and allows drill down to the sub report. When I run it in a .Net (Crystal 13.0.13) viewer app we've written, the drill down throws a 428 error. I can duplicate this 428 error running the main report if I remove the Prefix. We've also been able to store the procedure to the database without the Prefix and it operates properly. I believe there is a bug that is preventing this Prefix from being prepended in the .Net components. I am seeing the same behavior in the Visual Studio Crystal designer and during app execution.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers