Skip to Content

Master data of Infoojbect with HANA View not shows data

Hi.

I have created a Calculation View (Dimension format) for update de master data infoobject.

The calculation view is very easy, only one table with mandt and session cllient.

And the calculated view shows data:

The infoojbect is very easy too:

With the RSD1 i can see that always is ok,

But the master data aren't show

But the table contains records and they are show in the Calculated View.

I have try with Analytic View and Attibute view, too, but the result is the same and I have try to check the master data box in the infoobject but nothing occurs.

I have try some combinations (without language dependencie, etc etc) but nothing works.

Does the Calculated View or Infoobject require any specific configuration or feature?

Thnaks in advanced.

29iv8.png (35.2 kB)
eukbj.png (51.5 kB)
qudsc.png (22.1 kB)
sxjx0.png (12.1 kB)
40ry0.png (9.7 kB)
qaani.png (8.8 kB)
mq7ng.png (6.4 kB)
2mup7.png (16.2 kB)
ylmsa.png (34.8 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Aug 10, 2017 at 10:23 AM

    Hi Javier,

    what are the prerequisites to use the Read Access Type "SAP HANA View"?

    I would like to use the same approach as you, but in my case, it´s not possible to set the Read Acces Type to "SAP HANA View". I can only use the following Read Access Types in the InfoObject settings under the tab "Master Data/Texts":

    Via the BW backend t/code RSD2, I see the Master Data Access Type "SAP HANA View", but I can not change the access type:

    In the following blog post, I saw also comments with the same issue:

    https://blogs.sap.com/2016/04/28/how-to-create-and-maintain-info-objects-using-eclipse-data-modelling-for-sap-bw-75/

    Thanks in advance and best regards,

    Michael

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 28, 2017 at 01:19 PM
    Add comment
    10|10000 characters needed characters exceeded

  • Oct 17, 2017 at 10:26 PM

    Hi Javier, did you ever get an answer on this? I'm having a similar issue.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 19, 2017 at 04:30 PM

    Hi again.

    Reading the oss notes 2538757 and 1565809 I have found a workaround for the solution, but i think that something is wrong.

    I explain you the error.

    For the dimension /IECI/PRPPSB2 i have checked all posibilities for get the master data:

    In the infoobject:

    In the composite provider:

    And in the Bex query:

    But, when i execute the query throw the RSRT (with BICS) or Analysis for Office, the configuration for F4 help input is not taken for the report (the Members in InfoProvider is selected).

    I think that is not correctly.

    I do the same for the dimension /IECI/PRPPTPR, but i select the

    “Usable as Infoprovider” check,





    And the configuration is taken correctly.

    You can uncheck the option “Usable as Infoprovider” and the configuration is taken still.

    Kind regards.

    Add comment
    10|10000 characters needed characters exceeded