Skip to Content
0

No data types found. You cannot create message fields without a data type.(401 unauthorized)

Aug 10, 2017 at 01:20 PM

43

avatar image

Hi Team,

while trying to create the message type I am getting below error.

as per below link all the roles has been assigned .

https://help.sap.com/viewer/7436c3125dd5491f939689f18954b1e9/Cloud/en-US/c8532bcf28754b248dec71a518463865.html

but in console am getting 401 unauthorized error .

please suggest .

Regards

Dibyajyoti Nanda

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Anton Levin
Aug 10, 2017 at 07:13 PM
0

Hello Dibyajyoti,

in the logs I see "SAML2 - signature not valid" exception thrown each time your IoT Cockpit tries to access the IoT RDMS. I would suggest the following:

1. Open your SAP Cloud Platform Cockpit

2. Navigate to "Security" -> "Trust"

3. Open "Application Identity Provider" tab and check that you have "SAP ID Service" as a default provider.

4. Open "Local Service Provider" tab

5. Press "Edit" and change "Configuration Type" from "Default" to "Custom"

6. Press on "Generate Key Pair" and "Save" your changes

7. Press "Edit" again and change back to "Default" configuration type

8. Ensure your "Principal Propagation" is "Enabled"

9. Save your changes

10. After around 5 min try to open IoT Cockpit in a fresh browser session.

If this workaround won't work, I would need to contact Cloud Platform infrastructure colleagues and ask them to have a look what might be wrong with your account.

Regards,

Anton

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Anton,

Thanks for your help .

it worked ...!!!!!!!!

Regards

Dibyajyoti Nanda

0