Skip to Content
0

sapgenpse import_p12 -p SAPSSLS.PSE exportfile.pfx command is erroring

Aug 09, 2017 at 07:50 PM

710

avatar image
Former Member

I have a wildcard certificate that I have installed on many of my windows servers. I now need to install it on a linux server running Webdispatcher but receive this error when running sapgenpse.

sapgenpse import_p12 -p SAPSSLS.PSE test.pfx Please enter PKCS#12 encryption password: ******* Found key 'INDEX=0,SIG=YES,ENC=YES,MD5-FINGERPRINT=xxx,KEYID=xxx import_p12: Sorry, but certificate chain is incomplete, need certificate of 'CN=xxx

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Michael Healy
Sep 10, 2017 at 05:49 PM
0

You will need to supply the missing CA certificates to sapgenpse import_p12 as additional files with the "-r <CAcert.cer>" option (up to 10x for long cert chains...)

Add -v parameter if you want additional information in the output like the certificate chain

Share
10 |10000 characters needed characters left characters exceeded