Skip to Content

HTTP Rest Adapter - always calling the same Service Interface

I have tried to setup a HTTP Rest adapter to take JSON requests. I would like to setup one adapter to handle all the requests from our Hybris system.

For this Rest adapter, I need it to support 4 different calls:

Shipment

Registration

Sample

Request

I tried setting up the Rest adapter with the following settings:

Channel Selection:

Rest Resources:

Rest Operation:

Standard - no changes past default

Operation Determination:

This works to a point. It picks the correct Operation Determination but runs the wrong OM.

Here is a snippet of the log from a Registration attempt:

What am I doing wrong? Any advice?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Aug 09, 2017 at 03:12 PM

    Hi Brian,

    Based on the error it looks like it is triggering an incorrect mapping as per the operation that is setup in the configuration. The first place I would check is the integration flow configuration in relation to the operation mapping that is defined for each operation.

    Regards,

    Ryan Crosby

    Add comment
    10|10000 characters needed characters exceeded

    • You were correct, there was some issue with the 2 ico objects. I deleted (and activated that deletion) then re-created the ICO objects and now everything is working like I thought it should.

      Thanks!

  • Aug 09, 2017 at 03:03 PM

    I re-read my submission but I don't think I was very clear with the problem. When I try to send a "Registration" transaction to the HTTP REST Adapter, the adapter sees it as a Registration and picks the correct Service Interface.

    However the wrong Operation Mapping is actually called. The one that is called is for the Shipment transaction (not the Registration). These are on 2 very different Service Interfaces and Integrated Configuration Objects.

    If you can, I am looking for insight into what is going on. I also welcome any suggestions on how to better setup the HTTP Rest adapter.

    Add comment
    10|10000 characters needed characters exceeded