Skip to Content
0

Log viewer is not working

Aug 09, 2017 at 01:05 PM

717

avatar image

Hi,

We have NW 7.31 and log viewer is not working.It says"connection refused.log files are not loaded.please try after short time."

I have read different notes related to this error and found,in our production system,the parameter service/protectedwebmethods is set to SDEFAULT.But the log viewer was working perfectly with the same parameter value and suddenly it stopped working and also the same is working in non-production environment with the same parameter value.

Please help.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Adeel Khan
Aug 12, 2017 at 04:22 PM
0

Hello,

Most probably this issue is related to the new SAPControl web service (which the log viewer uses to read the logs) security. It has added another level of security in certain kernel versions. There is now a whitelist of contexts that can use the web service (regardless of authentication) and unfortunately the log viewer is not in the defaults. You can find more details regarding this in SAP Note 2427292.

To resolve the issue, you should add the following line in your default profile file (/usr/sap/<SID>/SYS/profile/DEFAULT.PFL) and restart the SAP Netweaver Application Server and the sapstartsrv service:
jstartup/service_acl = service:*;library:*;interface:*;sap.com*

Thanks and Kind regards

Adeel Khan

Share
10 |10000 characters needed characters left characters exceeded
Santarshi Samanta
Aug 11, 2017 at 07:04 AM
0

Hi

Can you please attach the error screenshot along with the screenshot of the steps you are following.

Also provide the portal version you are using.

Regards

Santarshi Samanta

Follow @santarshi.samanta

Share
10 |10000 characters needed characters left characters exceeded