Skip to Content
avatar image
Former Member

Visual administrator not loading

Hi All,

Recently we are getting an error "com.sap.engine.tools.launcher.Launcher Error" while loading the visual administrator.Please see the attched log

we are working in SAP XI 3.0 AS400 i Series/DB2.Please help.Checked the java_home parameter C:\j2sdk1.4.2_13 as this and it was working properly.

Y:\usr\sap\c42\DVEBMGS42\j2ee\admin>"C:\j2sdk1.4.2_13\bin\java" -showversion -Ds

un.java2d.noddraw=true -Duser.language=en -DP4ClassLoad=P4Connection -Dp4Cache=c

lean -jar "Y:\usr\sap\c42\DVEBMGS42\j2ee\admin\go.jar"

java version "1.4.2_13"

Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_13-b06)

Java HotSpot(TM) Client VM (build 1.4.2_13-b06, mixed mode)

8/8/07 3:41 AM com.sap.engine.tools.launcher.Launcher Error : unable to invoke m

ain class com.sap.engine.services.adminadapter.gui.AdminFrameView

Exception in thread "main" com.sap.engine.tools.launcher.LauncherException

at com.sap.engine.tools.launcher.Launcher.launch(Launcher.java:340)

at com.sap.engine.tools.launcher.Launcher.main(Launcher.java:114)

-


caused by -


java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.

java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces

sorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at com.sap.engine.tools.launcher.Launcher.launch(Launcher.java:336)

at com.sap.engine.tools.launcher.Launcher.main(Launcher.java:114)

Caused by: java.lang.NoClassDefFoundError: javax/management/MBeanFeatureInfo

at com.sap.engine.services.adminadapter.gui.node.MBeanNodeView.initView(

MBeanNodeView.java:62)

Thanks

Hany

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Aug 08, 2007 at 11:06 AM

    Hi,

    change the HTTP port no to 50004 in visual admin and your central instance no is :00

    If your instance is different, change the port no by this format 5<central instance nr>04

    It should work.

    ravi

    Add comment
    10|10000 characters needed characters exceeded