Skip to Content
avatar image
Former Member

PI not receiving some fields

Hi,

This is an IDOC to IDOC. we did a direct mapping and everything is working but PI did not receive some fields even though it is a direct mapping. Client was saying the Idocs are not getting failed in their system but in the idoc particular status not contain the required field.

Please Advice....

Thanks

Mathi

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Aug 09, 2017 at 09:28 PM

    Mathi,

    • Whatever IDOC you are using at sender side and receiver make sure you have the same version which is being used in ECC system if not re-import them in ESR.
    • Delete the IDOC metadata and reload back it again.

    Br,

    Manoj

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Manoj,

      Yes, i have re imported the new version whatever ECC having right now.I did not delete the idoc, let me try and i will let you know.

      Thanks for your support.

  • avatar image
    Former Member
    Aug 09, 2017 at 09:06 PM

    Hi Mathi,

    Can you share us more details on this,

    What is the idoc that you are trying to send and what is the field that is missing?

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 09, 2017 at 10:49 PM

    Hi Selva,

    Thanks for your prompt reply.

    Please find the below detail:

    The below data not received by PI from ECC.

    Idoc MATMAS05 to 06

    1. Filed under E1MARAM

    MSTAE----ZMSTAE (0..1)

    2. ZMARAEXT

    ZCLASS_IND------ZCLASS_DEL (0..1)

    in the above fields are direct mapping even after re import the idoc we did not receive the field in PI.

    Thank!

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hello Raghu,

      Thanks for your valuable answer.

      We tried that too but it is not working. Is there any other way for this?

      one i doc is standard and another one is customized. even after re imported the metadata under IDX2 it is not working.

  • Aug 16, 2017 at 08:18 AM

    Is that control records? Make sure you mapped it right or parameteriezed it.

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 15, 2017 at 01:16 AM

    Hi Mathi,

    Is your Z fields or fields under Z segment are not coming in output or it is related to other fields as well? Please check if the IDOC extension is release from ECC using transaction WE30 and WE31 in ECC.

    regards,

    Harish

    Add comment
    10|10000 characters needed characters exceeded