Skip to Content
avatar image
Former Member

SAPbobsCOM.Company.90.0 Description: You are not connected to a company

We receive the above error when connect by Web service call. All of the SLD components connect properly when tested. We are using version 1.22.10 of B1i against v9.0 PL11 of SAP Business One.

Anyone have any ideas?

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Aug 21, 2017 at 01:11 PM

    we are facing the same problem using B1iSN 1.22.11 and B1 9.0 PL12

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 22, 2017 at 10:45 AM

    please try this:

    Basically this issue is due to the System Landscape Directory changes since SAP Business One 9.2 PL05. There is a new parameter introduced to DI API: sldServer (this field doesn't exist in the old B1iSN as well). For the new DI API it prefers to use this instead of "licenseServer" to connect which means you can use either of these two parameters to get a DI API connection, however in the old DI API prior to SAP Business One 9.2 PL05, there is no such parameters which will cause a problem if you setup both under B1DI even though the B1DI connection works when clicking "Test Connection". This error - "You are not connected to a company" can only be found during the runtime. In order to solve the issue, please leave the "sldServer" empty for the 9.0 companies and check the runtime message again. If the issue persists, please try to leave "sldServer" & "licenseServer" both empty and retry the test.

    Add comment
    10|10000 characters needed characters exceeded