Skip to Content

Image URL on Sharepoint used in WebI 4.2 - Export to PDF doesn't show the image


I already posted this question 10 days ago, but due to the migration it vanished somewhere in the depths of the SCN-archive.

Just to be sure it will be found in the new Q&A Section, I repost it hereby:

Our current system is BOBJ 4.2SP2 on Windows.

Our problem is exporting a WebI Report containing an image implented via Image-URL to PDF.

I tried all the following things in HTML-mode, so I'm not talking about Applet-mode...

The image doesn't show up in the PDF, when the URL is pointing to a MS-Sharepoint, which of course underlies certain user-credential-settings. It does show up in the PDF if the URL is pointing to an 'open' webserver on our LAN.

Settings described in the User Guide like putting some registry-keys in HKLM\...\BlobManager or changing the 'Read content as' in the Cell-Formatting window in the report do not affect this behaviour in any way; neither positive nor negative.

I see both images in my report in my local browser.

What I think to have discovered up to now:

Seeing the report in my browser (IE 11) means that the URL is resolved on my client, sending SSO Credentials to the Image-URL-Server whenever needed.

Exporting the report to PDF results in downloading the PDF in the browser meaning the PDF is created on the BO-server.

We have tried running SIA- and Tomcat-Service as a windows user with needed permission to the Sharepoint. So if I open the Image-URL in a browser on the server as the same windows user who runs the services, I see the image in the browser.

Nevertheless exporting the report results in no image in the PDF.

I think the problem is, that PDF-generation on the server is resolving the URL (as it works with images on 'open' servers) but not sending any SSO-credentials or Authentication-Headers when resolving the URL.

Am I right in that assumption?

And if yes, what can we do??

In our company we have software putting certain images to certain Sharepoint-folders which are dynamically included into certain BO reports. Putting these images to an 'open' webserver is no option.

Best regards, Ewald

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Sep 29, 2017 at 01:47 PM


    The problem here is that the server have no access to the image due to the HTTP-Authentication. You can see that via the error message.

    Could you please set the URL as background image of a cell and set it's type to stretch? Normally, the image shouldn't be displayed in that case also cause we need to retrieve it, resize it then display it which shouldn't work if we can't access it.

    Best Regards,


    Add comment
    10|10000 characters needed characters exceeded

    • Hello Slim,

      I just had a phone call with Adam and we went through your questions. No changes. Images are still visible in WebI, but when exporting them to PDF, the image from Sharepoint is not there. No matter if streched or not. Same behaviour.

      I again told him, what I also told here. In WebI, the URL to the image is resolved in the browser. The browser handles HTTP-Authentication (Windows-Credentials SSO) with the Sharepoint server and WebI can display the image.

      When exporting to PDF, the server is generating the PDF. So WebI Server tries to resolve the URL and get the image from Sharepoint server. Sharepoint server asks for authentication. WebI Server ignores (as it wouldn't have any credentials for authentication anyway) and displays an empty cell.

      Best regards, Ewald

  • Oct 13, 2016 at 11:37 AM

    Hi ,

    Did you try scheduling document output as PDF ?

    Can you open the sharepoint images with the URL from BOBJ server ?

    Thank you


    Add comment
    10|10000 characters needed characters exceeded

  • Oct 13, 2016 at 02:58 PM


    no, I did not try scheduling the document, as it wouldn't be an option for our needs. Would it help to narrow the problem?

    Yes, as mentioned above.

    If I enter the sharepoint image URL directly in the browser (let's call it http://sharepoint.local/test.png), i see the image; no matter if I try with the browser on my laptop or with the browser on the BOBJ Server.

    If I use the sharepoint image URL as Image Hyperlink in the report, I see the image in the report; no matter if on laptop or on server.

    If I export this report as PDF, I don't see the image in the PDF; no matter if on laptop or on server.

    I still guess it's a matter of HTTP-Authentication (SSO). While in the browser, the browser deals with authentication headers and so on. Exporting the report results in some server module resloving the URL and trying to GET the image, not caring about any authentication...

    Just an assumption though, but for me the most plausible explanation...

    Best regards, Ewald

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 19, 2016 at 03:04 PM

    Are there any logs on the sharepoint server showing "Who" is trying to access the image? (I'm guessing a 401 response from sharepoint).

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 28, 2016 at 12:49 PM

    There are logs on the sharepoint but I captured request and response with a web debugger acting as a proxy.

    This is the request sent by the BOBJ-Server wheren creating the PDF:

    GET http://sharepoint.server/path/to/testimg.png HTTP/1.1
    Host: sharepoint.server
    Accept: */*
    Connection: Keep-Alive

    This is the (expected) response from the Sharepoint-Server:

    HTTP/1.1 401 Unauthorized
    Content-Type: text/plain; charset=utf-8
    WWW-Authenticate: NTLM
    Date: Fri, 28 Oct 2016 11:49:14 GMT
    Content-Length: 16
    Proxy-Support: Session-Based-Authentication


    Seems like a dead-end. Any ideas?

    As we are in the middle (or rather almost at the end) of our migration process from 3.1 to 4.2, this definitely is a show-stopper. We have to provide this functionality to our users.

    Add comment
    10|10000 characters needed characters exceeded