Skip to Content
avatar image
Former Member

HANA Express installation fails on a 16GB Intel NUC ->deactivate memory check for hdblcm?

Hi guys,

yesterday I tried to install the current version of HANA Express on a 16GB Intel Nuc Centos based. Inside the installation guide is written, that 16GB is minimum -> adding swap-file will solve some memory issues.

But the result is the following:

Installation failed -> Checking minimum memory requirement failed --> Physical memory on this host is 15.387 GB. Minimum required: 24GB.

Is there any option to deactivate the memory check -> I think the performance will be ok for my small use case.

Thanks Stephan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Aug 08, 2017 at 07:41 AM

    You can try with:

    ./hdbinst --ignore=check_min_mem

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Bartosz,

      I found that this parameter exists and tried it by editing the

      setup_hxe.sh script. but I think I didn´t found the correct line for it.

  • Aug 16, 2017 at 11:37 PM

    @Stephan,

    Are you using the setup_hxe.sh script (as documented) or hdblcm directly (not supported)? Are you installing the server only or server + XSA?

    Chris

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Stephan,

      Did you do the changes in 'setup_hxe.sh' script? Can you provide the line number or command that you modified for ignoring the memory check.

      Thanks,

      Vish

  • avatar image
    Former Member
    Jan 18 at 09:03 PM

    Hello Stephan,

    I get exactly the same error message installing SAP HANA Express on my NUC:

    Checking minimum memory requirement failed

    Physical memory on this host is 15.557 GB. Minimum required: 24 GB.

    Did you manage to skip this check?

    Add comment
    10|10000 characters needed characters exceeded