Skip to Content
0

Record Selection Formula Problems

Aug 08, 2017 at 01:39 PM

22

avatar image
Former Member

I am using a command object containing PL-SQL (Oracle). I have three record selection parameters, a beginning date, and ending date and a facility. Facility is numeric with a default of zero for all facilities. When I run it with 0 for the facility parameter, it returns no records. If I run the same SQL in SQL developer, it returns data. The line in the code that uses the facililty parameter is:

where (rev_loc_id in {?Facility} or 0 in {?Facility} )

I tried

(rev_loc_id in {?Facility} or {?Facility}=0 ) but that does not work either.

The SQL itself runs to 145 lines and has three WITH clause constructs.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Ian Waterman Aug 09, 2017 at 08:21 AM
0

Try

({?Facility}=0 or rev_loc_id = {?Facility} )

I assume ?Facilty is a multiple value parameter, I find = works rather than in

Ian

Share
10 |10000 characters needed characters left characters exceeded