Skip to Content
0

SAP Cloud Appliance Library using HANA Studio

Aug 08, 2017 at 07:42 AM

93

avatar image

I have created a new instance of SAP BW/4HANA SP03 including BW/4HANA Content SP01 XT. I can connect to it from SAP GUI, but I cannot connect using HANA Studio.

I can connect using ssh and I can see the processes are running using:

sapcontrol -nr 02 -function GetProcessList

But I cannot connect using hdbsql commands through ssh. I get 'Connection Refused' or 'Authentication failure', depending on what I try to do.

What am I doing wrong to get to connect using HANA Studio?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
avatar image
Former Member
Aug 09, 2017 at 09:08 AM
0

Hello Al,

This easiest way would be to use the pre-installed SAP HANA Studio available on your frontend instance. In the HANA Development perspective there you can find a pre-configured connection to your HANA system. More details are provided in section 5.3 of the getting started guide for BW4HAHA solution - https://caldocs.hana.ondemand.com/caldocs/help/Getting_Started_Guide_BW4HANA_DeveloperEdition.pdf

Let me know if this scenario is not working for you?

Best Regards, Rado

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member
Aug 08, 2017 at 08:43 AM
0

Hello Al

Have you tried to start hdbsql from the ssh client e.g. putty or you tried to run hdbsql on your machine and tried to connect from there?

In case you want to login from your local studio or command line client you’ll need to use the pem file to login.

Best Regards, Rado

Share
10 |10000 characters needed characters left characters exceeded
Al McEwan Aug 08, 2017 at 11:56 AM
0

Yes, I have been tried using hdbsql from the ssh client.

The challenge is that I cannot connect to HANA directly, either using hdbsql or HANA Studio. HANA Studio is what I want.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 05, 2017 at 06:08 PM
0

Hi Al, did you ever get the HANA Studio to BW4HANA XT solution working? If so, how? I'm having the same issue. I've added all the access points (32015, 32016, basically all the ones that are autocreated on the non-XT version of the BW4HANA solution) and that's allowed me to connect via SAPGUI, but still can't get HANA Studio to work. Network guys say the connection isn't blocked but I'm getting an rst from the server...

Share
10 |10000 characters needed characters left characters exceeded