Skip to Content
0

Application Initialization is failed due to cannot read property getResourceBundle() of undefined

Oct 10, 2016 at 01:54 PM

324

avatar image
Former Member

capture.png

Hi All,

After deploying the Custom UI5 application in fiori launchpad, We are facing the below error kindly help me on this issue.

Regards

Sravya

capture.png (137.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

avatar image
Former Member Nov 01, 2016 at 09:25 PM
0

Hi,

I see you have deployed it to gateway. What version do you have on gateway?

http ://<server>:<port>/sap/public/bc/ui5_ui5/index.html

and which version you have used in your sapui5 app (set in the template by creating.

Seams to be a missmatch of the versions.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hello Silvia,

Can you please help me on this , my Gateway version is 1.28 and my UI5 application template was fiori master-detail and the version is 1.32.6.

1. Is the above error route cause is version compatibility?

2.How can we handle the version compatibility, UI5 applications are frequently upgraded, is it necessary to upgrade the Gateway version also?

Totally confused , Kindly help me on this.

Application is successfully executed in SAP-WEBIDE, but after deployed in fiori launchpad we are facing errors.

The version should same in UI5 application and Gateway its working fine.

Thanks®ards

Sravya

0
avatar image
Former Member Feb 07, 2017 at 03:19 PM
0

1. yes it seams so. As some methods are not available with 1.28 which you have used.

2. No you can still develop with webide. Please ensure that you use as template 1.28 version and also test it it that version over hcp (there is a setting in the webide where you can set the version in which it should be run)

The app is successfully runnin gin webide as you using there the library mention in your template. if you run it on fiori launchpad on gateway you use the library version on gateway. So please create the project once new with the template equal with version on your gateway.

Share
10 |10000 characters needed characters left characters exceeded
Jun Wu Feb 07, 2017 at 03:58 PM
0

as long as you are not using any api from higher version, you should be fine. can you comment out the line code to see if you can run your app from flp?

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 09 at 06:01 AM
0

Hi Sravya,

Could you please tell me how did you resolve the issue. I am getting the same issue. I am using worklist template version 1.40.

You faced this issue with 1.28 master-detail page but I am using 1.40 worklist.

So what should I do now to resolve the error?

Can you tell me the reason behind this?

Any Support packages to be installed? I am totally confused

Thank You,

Srikar Nagadevara

Share
10 |10000 characters needed characters left characters exceeded