Skip to Content
0

SAP BO 4.1 Restore for Disaster Recovery

Aug 07, 2017 at 07:29 PM

120

avatar image

Hello experts,

I need some help from you.

I need to restore (like in a disaster recovery mode) a whole BO environment.
At this the new BO environemt has the same Support Pack and patch version 4.1 SP8 FP8).

The tasks I have done so far are:
- I generated a copy [backup] of the (I/O) FRS and the CMS DB of current environment
- Installed a new BO deployment
- Copied the FRS and CMS DB from the backup.
- Copied the file "dbinfo" from old into new BO environemnt

However, none of the servers but the CMS are starting. Should I use the CCM to point to the CMS DB even if I have already copied the "_boe_<sia_name>.dbinfo" file.

Do you have any sugestion?

I remember that once I have done with BO 3.1. At that time I needed to change the "bootstrap" file, but I'm not sure about BO 4.1.

Any comments is highly appreciated.

Thanks!
Marcos

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Ajay Gupta Aug 07, 2017 at 07:36 PM
1

Marcos,

See link to blog that show step-by-step on how to restore from back-up for DR Purpose

https://blogs.sap.com/2015/08/24/how-to-restore-bi4-from-frs-cms-backup/

Regards,

Ajay

Show 1 Share
10 |10000 characters needed characters left characters exceeded

That was really helpful Ajay! I will test and revert.

I previously had a look in admin guide, but it's not to friendly in such task.

Thanks for now, I will test...

0
Graham Farr
Aug 10, 2017 at 08:30 AM
1

Hi Marcos,

For future reference, the information is also contained within the following KBA:
1275068 - Backup & Restore XI 3.x / BI 4.x from one environment to another [video]

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Graham, for sharing!

0
Denis Konovalov
Aug 07, 2017 at 08:15 PM
0

If you follow this method and your original environment and the new one are on the same network - you'll have issues.
Also, if it is windows, you can't simply restore binaries and bootstrap files and expect stuff to work.

If it is *nix - it might work, but still not a right sting to do.

For the process to work you need :
1. make sure original environment is either down or network segregated.
2. Install new installation of the same BOE version as original env. then point it to restored CMS DB and FRS
If you're on *nix and want to restore binaries/directories - make sure server name is same as original.(still not recommended/reliable).

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Denis,

Thank you for taking some time tom reply.

I'm in Unix environment. The copy worked, only the servers were not starting.

I have recreated the node (but through serverconfig.sh) as per Ajays' suggestion.

I' worked.

Marcos

1