Skip to Content
1

Issue in ABAP in Eclipse on Linux

Aug 07, 2017 at 08:23 AM

170

avatar image

Hi folks,

I have installed SAP GUI for Java 7.40 rev 12 on Ubuntu (17.04). Then I installed Eclipse Oxygen and ADT tools for ABAP development.

But I have a strange issue in Eclipse :

  • When I use use 'Open SAP Gui' (Ctrl + 6) button to open any transaction (say se11) and open tables etc., everything works fine.
  • But if I use the same button to open any code (through se38/se37/se80 etc.) the screen starts to flicker rapidly. It becomes impossible to work after that. The only way is to restart Eclipse.
  • Strangely using 'Open ABAP development Object' (Ctrl+Shift+A) button to search and open the same report/FM etc. does not cause any flicker and I am able to work fine.

Initially I thought it may be bug with Eclipse Oxygen, so I went to Eclipse Neon version, but same issue was there too. I even checked with a friend, who noticed same issue so I am sure the issue isn't only on my machine.

I installed SAP Gui 7.50 on Windows (native client) and then Eclipse Oxygen/SAP ADT, but I didn't find this issue in Windows.

So, I suspect it's either issue with Linux client or SAP GUI Java. Any suggestions to resolve this issue?

Thanks,

Ravi

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Marco Hernandez Oct 18, 2017 at 10:51 AM
1

Hi Ravi,

Today I had exactly the same bug. Somehow Eclipse does not like to work with GTK3. So what I did was to include this line in the eclipse.ini file:

--launcher.GTK_version

2

That did the job! Now I can display any SAP transaction and debug from eclipse.


Show 2 Share
10 |10000 characters needed characters left characters exceeded

Interesting, but if it's GTK then why only start freaking out when SAPGUI does it's thing.

I wonder if SAPGUI likes GTK2 and Eclipse GTK3. So maybe updating to SAPGUI 7.5 might also do the trick...?

0

Thanks Marco. Will also try it out and get back to it.

0
Mike Pokraka Aug 07, 2017 at 08:53 AM
0

My guess is that it's either to do with java or eclipse-sapgui integration.

Do you get flickering if you start sapgui directly - i.e. bypassing eclipse altogether?

If so then the issue is with your java or the java gui. If not, then it's java or the eclipse-sapgui integration.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

It works fine in SAP GUI Mike. But SAP GUI on Linux being Java based doesn't support 'new' ABAP editor. Hence, I would like to use ABAP on Eclipse on Linux .

The issue is definetly with Eclipse-SAPGUI integration. But I am not sure which is the correct team to handle this issue. Eclipse or ADT (ABAP Development Tools) plugin team.

0

Using pure SAPGUI was just a troubleshooting exercise. Have you tried updating to 7.5 GUI and the latest JVM?

0
avatar image
Former Member Mar 29 at 07:59 AM
0

I have the same problem, so it's not just you. I am on Fedora 28 and can reproduce the issue both in xfce as well as gnome3. Former Member solution (calling `eclipse --laucher.GTK_version 2`) causes eclipse to reproducably crash when opening a report (not a class or function module!) and starting to scroll.

Share
10 |10000 characters needed characters left characters exceeded