Skip to Content
author's profile photo
Former Member

No records in delta queue for 0CRM_SALES_ACT_1 & 0CRM_COMPLAINTS_I

Hi all,

we are linking a SAP CRM system 4.0 (patch level 10) with BW 7.0. We have initialized the delta extraction and everything was fine. Data was extracted and we can see the delta queue in RSA7 but no records are added. Users are creating new activities and nothing appears in the delta queue. We have other extractors delta capable which are working fine.

The main difference is that these two extractors have been enhanced using the Badi CRM_BWA_MFLOW. When we check the extractor using transaction RSA6, records include the information we add in the Badi.

We think the problem is in CRM because, it does not collect any delta data (queue is always empty). BW is capable to extract when initilitialization. We have tried the early delta initialization and the simple delta initialization.

Any help will be appreciated.

Thank you in advance.

As an extension: we can't see the extractors in the qRFC monitor (trans. SMQ1). We can see there the ones which are working...

Message was edited by:

Ignacio Llopis

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • author's profile photo
    Former Member
    Posted on Aug 03, 2007 at 07:55 AM

    Hi again,

    we finally solved the problem. The thing was that no BDOCS with type BUS_TRANS_MSG were not being generated when creating or modifying CRM activities. Theses datasources need the BDOCS to work. Transaction SMW3_00 had the flag "Do Not Send" set. We unmarked it and everything seems to work now.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      hi,

      I have a similar problem in SRM (with few Queues visible in RSA7 that are not delta updating - and they are not available as Queues in SMQ1).

      Those that are in the smq1 are delivering delta fine.

      I checked on the tx smw3_00 - but in my SRM system there is no entry in that BDOC Customizing table.

      Any help?

      thanks,