Skip to Content
avatar image
Former Member

DropDownByKey rendering bug

I have received a defect report against my Web Dynpro application that I believe is due to a bug in the Web Dynpro renderer. I would appreciate any help the user community might provide.

In the application a DropDownByKey control is used to display the list of selections to the user. Normally, this control is rendered such that the font in the drop down list is the same as that used when the control is not dropped down (closed).

On one of our portals there exists what I consider to be a bug in the SAP Web Dynpro renderer: A very large font is used to render the drop down list. The size of the drop down box is apparently computed using the correct font size, the effect being that some of the entries are clipped off the bottom of the list. No scroll bar is displayed

This leads the user to assume that some of the expected entries are not in the list.

If the user is aware of the problem, he can work around it by using the down arrow key on the keyboard rather than using the mouse to drop down the list and select from it.

I have seen this problem intermittently on some of our other J2EE engines. When I have seen this before, simply closing the drop down list and dropping it down again, the list would then render correctly. This makes me believe this is a bug in the SAP renderer.

I would appreciate any help or insight.

Thanks in advance,

Kelly

P.S. I have screen captures that illustrate the problem. If you e-mail me at

kelly.mulheren at ngc dot com, I can send them to you.

P.P.S. I don't have the software version numbers handy but can provide them if need by. We're running pretty recent 2004s, though.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Aug 02, 2007 at 07:58 AM

    I know this effect. Sometimes it helps to just clear the browser cache such that the style sheets are reloaded. If this does not help, please open an OSS message (BC-WD-CLT-HTML).

    Armin

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Armin,

      I tried clearing the Internet Explorer browser cache but, unfortunately, it did not correct the problem. Tried multiple times.

      I will open an OSS message as this is a serious problem for our users that are not very sophisticated with GUIs.

      Thanks for your suggestion. It would have been a good workaround.

      Best regards,

      Kelly

  • avatar image
    Former Member
    Aug 09, 2007 at 02:16 PM

    Update:

    We entered an OSS message for this problem and got the following response:

    <i>

    I had talked to my colleagues who are responsible for rendering and

    according to them this was a bug and will be solved if you apply the

    latest hotfix.</i>

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 02, 2007 at 08:24 AM

    hi

    Very true. I have faced this on 2004 and on 2004s. And even now as I was using a Webynpro App in the enterprise portal it occurred. It happens with the quick select in Tab strips too. I am on 2004s sp9.

    regards

    LNV

    Add comment
    10|10000 characters needed characters exceeded