Skip to Content

Modal Form Event handling? (continue)

I am following this archived question:

http://archive.sap.com/discussions/thread/3965886

@pedro.magueija

"How did you add it to your project references? Did you use the Add Reference -> Assemblies in Visual Studio (recommended)? Or did you browse to the SDK path and added that?"

I added manually, in Visual Studio -> add reference -> browse. The COM category only has the separate dlls for me.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Oct 13, 2016 at 08:28 PM

    Hi Szabolcs,

    Just an attempt, in your project reference, click on the SAPBusinessOneSDK.dll and in the properties tab, check if the option Embed Interop Types = False, like the image. If no change this option and run again your program.

    Hope it helps.

    Kind Regards,

    Diego Lother


    img.png (7.0 kB)
    Add comment
    10|10000 characters needed characters exceeded

  • Oct 20, 2016 at 05:19 PM

    Hi Szabolcs,

    The SAPBusinessOneSDK.dll is not in the COM section anymore. It's now in the Assemblies section.

    Try referencing the one there. I believe the new SDK is installed to the GAC and you might have multiple version on your system.

    Referencing from there will take the most up-to-date.

    Perhaps that could be the issue?

    Pedro Magueija
    LinkedIn | Twitter | Blog


    sdk-ref.png (21.3 kB)
    Add comment
    10|10000 characters needed characters exceeded