Skip to Content
0

personal sapwebide cannot connect to on prem ERP

Oct 10, 2016 at 04:28 PM

576

avatar image
Former Member

When accessing the service it says catelog service is not available

when do a run F12.http://localhost:8080/webidedispatcher/destinations/[Server]/sap/opu/odata/IWFND/CATALOGSERVICE;v=2/ServiceCollection?$format=json

it says 404 error. Is there something missing. please let me knwo

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Jeremy Good
Oct 10, 2016 at 04:30 PM
0

You might want to explore the developer guide a bit more: https://wiki.scn.sap.com/wiki/display/ATopics/SAP+Web+IDE+-+Personal+Edition

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Oct 11, 2016 at 12:57 AM
0

I added the destination file as per the document on personal edition. But no luck

Description=DV4 Type=HTTP TrustAll=true Authentication=NoAuthentication Name=DV4 ProxyType=Internet URL=http\://url\:9004 WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap,odata_gen WebIDESystem=DV4 WebIDEEnabled=true sap-client=910

Any clue

Share
10 |10000 characters needed characters left characters exceeded
Sung-Yen Yang Oct 11, 2016 at 02:14 PM
0

Hi Mahesh,

Did you enable /sap/bc/adt service via T-Code SICF in your gateway system?

Also, check section 4.2.1 Requirements for Connecting to ABAP Systems in the document.

My WebIDE personal edition has no problem to pull UI5 projects from my ABAP server.

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

could you take a look at the problems which I am having?

0
avatar image
Former Member Oct 12, 2016 at 12:15 AM
0

Yes we installed the local host and /sap/bc/adt service is enabled.

And

when it access this URL it fails

http://localhost:8080/webidedispatcher/destinations/DV4/sap/opu/odata/IWFND/CATALOGSERVICE;v=2/ServiceCollection?$format=json

but i could access the http://[server]/sap/opu/odata/IWFND/CATALOGSERVICE;v=2/ServiceCollection?$format=json directly

I checked for oss notes too

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

did you find any solutions regarding this? I am also having the exact same issue connecting to an on-premise situation.

0

Hi,

Please share how you configured your destination including what is the file name.
Also please specify the failed request in the network trace of your browser.

Regards,
Michal.

0
Leandro Freidenberg PP Jun 21, 2017 at 09:15 PM
0

I know this is an old post, but has anybody found the solution to this? I´m having the exact same issue.

Thanks,

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Please share how you configured your destination including what is the file name.
Also please specify the failed request in the network trace of your browser.

Regards,
Michal.

0