Skip to Content
avatar image
Former Member

personal sapwebide cannot connect to on prem ERP

When accessing the service it says catelog service is not available

when do a run F12.http://localhost:8080/webidedispatcher/destinations/[Server]/sap/opu/odata/IWFND/CATALOGSERVICE;v=2/ServiceCollection?$format=json

it says 404 error. Is there something missing. please let me knwo

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Oct 10, 2016 at 04:30 PM

    You might want to explore the developer guide a bit more: https://wiki.scn.sap.com/wiki/display/ATopics/SAP+Web+IDE+-+Personal+Edition

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 11, 2016 at 12:57 AM

    I added the destination file as per the document on personal edition. But no luck

    Description=DV4 Type=HTTP TrustAll=true Authentication=NoAuthentication Name=DV4 ProxyType=Internet URL=http\://url\:9004 WebIDEUsage=odata_abap,ui5_execute_abap,dev_abap,odata_gen WebIDESystem=DV4 WebIDEEnabled=true sap-client=910

    Any clue

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 11, 2016 at 02:14 PM

    Hi Mahesh,

    Did you enable /sap/bc/adt service via T-Code SICF in your gateway system?

    Also, check section 4.2.1 Requirements for Connecting to ABAP Systems in the document.

    My WebIDE personal edition has no problem to pull UI5 projects from my ABAP server.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Oct 12, 2016 at 12:15 AM

    Yes we installed the local host and /sap/bc/adt service is enabled.

    And

    when it access this URL it fails

    http://localhost:8080/webidedispatcher/destinations/DV4/sap/opu/odata/IWFND/CATALOGSERVICE;v=2/ServiceCollection?$format=json

    but i could access the http://[server]/sap/opu/odata/IWFND/CATALOGSERVICE;v=2/ServiceCollection?$format=json directly

    I checked for oss notes too

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 21, 2017 at 09:15 PM

    I know this is an old post, but has anybody found the solution to this? I´m having the exact same issue.

    Thanks,

    Add comment
    10|10000 characters needed characters exceeded

    • Please share how you configured your destination including what is the file name.
      Also please specify the failed request in the network trace of your browser.

      Regards,
      Michal.