Skip to Content
0

consume XSOdata with SAPUI5 using Dev webide

Aug 03, 2017 at 02:40 PM

146

avatar image
Former Member

I've configured my destination as below

I'm unable to access my service in webide. I've tried with basicAuthentication but it give me 503 Error. in this case service is okay, but in my network tag (metadata) show some sort of authenticaiton Error. lot of HTML with some error as below.

I've also go through some solution like xs-odata-in-webide but this is for trial account. I need solid solution which should work with real deta insead of mock server

destination.png (14.6 kB)
metadata.png (28.1 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Srikanth KV Aug 03, 2017 at 03:48 PM
0

show your manifest.json where the model is defined along with the datasources....this is the place where path to xsodata service is set.....

Show 3 Share
10 |10000 characters needed characters left characters exceeded
Former Member
"dataSources": {
		"dlesContent": {
		"uri": "/destinations/dles/DLES/services/DLES_CONTENT.xsodata/NPS_CONTENT",
		"type": "OData",
			"settings": {
				"odataVersion": "2.0"
			}
			}
		},
//model is 
	"models": {
			"i18n": {
				"type": "sap.ui.model.resource.ResourceModel",
				"settings": {
					"bundleName": "dlesDLESdashboard.i18n.i18n"
				}
			},
			"dlesScore": {
				"dataSource": "dlesContent"
			}
		},


0

dataSources uri should point to.xsodata....remove the last entry after xsodata.

"dataSources": {
		"dlesContent": {
		"uri": "/destinations/dles/DLES/services/DLES_CONTENT.xsodata",   //changed line
		"type": "OData",
0
Former Member
Srikanth KV

still same response, Nothing changed

0