Skip to Content
avatar image
Former Member

Error in Deploying Application...

Hi Everyone...

I have created a Java Application using AbstractPortalComponent in NWDS. As I am trying to deploy the application I am getting the following error in log

[29.07.07 / 08:58] #ERROR LEVEL# com.sap.portal.developmentTools.ideSpecific.eclipse.wizards.sapmakepar.SAPMPWizard$1 > No Information

java.io.IOException: Server returned HTTP response code: 500 for URL: http://192.168.1.11:50100/irj/servlet/prt/portal/prteventname/upload/prtroot/com.sap.portal.runtime.system.console.archiveuploader?login_submit=on&j_user=&j_password=null&j_authscheme=default&uidpasswordlogon=log%20on

at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:800)

at com.sap.portal.developmentTools.general.wizards.upload.DeployEngine.readResponse(DeployEngine.java:363)

at com.sap.portal.developmentTools.general.wizards.upload.DeployEngine.uploadPar(DeployEngine.java:435)

at com.sap.portal.developmentTools.general.wizards.upload.DeployEngine.deploy(DeployEngine.java:221)

at com.sap.portal.developmentTools.ideSpecific.eclipse.wizards.sapmakepar.SAPMPWizard$1.processUpload(SAPMPWizard.java:416)

at com.sap.portal.developmentTools.ideSpecific.eclipse.wizards.sapmakepar.SAPMPWizard$1.run(SAPMPWizard.java:350)

at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:302)

at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:252)

at org.eclipse.jface.wizard.WizardDialog.run(WizardDialog.java:758)

at com.sap.portal.developmentTools.ideSpecific.eclipse.wizards.sapmakepar.SAPMPWizard.performFinish(SAPMPWizard.java:531)

at org.eclipse.jface.wizard.WizardDialog.finishPressed(WizardDialog.java:608)

at org.eclipse.jface.wizard.WizardDialog.buttonPressed(WizardDialog.java:321)

at org.eclipse.jface.dialogs.Dialog$1.widgetSelected(Dialog.java:423)

at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:89)

at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:81)

at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:840)

at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:2022)

at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:1729)

at org.eclipse.jface.window.Window.runEventLoop(Window.java:583)

at org.eclipse.jface.window.Window.open(Window.java:563)

at org.eclipse.ui.actions.ExportResourcesAction.run(ExportResourcesAction.java:112)

at org.eclipse.jface.action.Action.runWithEvent(Action.java:842)

at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:456)

at org.eclipse.jface.action.ActionContributionItem.handleWidgetEvent(ActionContributionItem.java:403)

at org.eclipse.jface.action.ActionContributionItem.access$0(ActionContributionItem.java:397)

at org.eclipse.jface.action.ActionContributionItem$ActionListener.handleEvent(ActionContributionItem.java:72)

at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:81)

at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:840)

at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:2022)

at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:1729)

at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1402)

at org.eclipse.ui.internal.Workbench.run(Workbench.java:1385)

at com.tssap.util.startup.WBLauncher.run(WBLauncher.java:79)

at org.eclipse.core.internal.boot.InternalBootLoader.run(InternalBootLoader.java:858)

at org.eclipse.core.boot.BootLoader.run(BootLoader.java:461)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:324)

at com.sap.ide.eclipse.startup.Main.basicRun(Main.java:291)

at com.sap.ide.eclipse.startup.Main.run(Main.java:789)

at com.sap.ide.eclipse.startup.Main.main(Main.java:607)

Any help in this regards will be highly appreciated.

Cheers,

Vivek

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 29, 2007 at 08:47 AM

    Your user and password dont seem to appear in the URL.

    Try checking if thats configured in the Portal preferences in nwds

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Prem,

      I have the parameters set under Prefrences in NWDS...For the time being for deploying par files I am logging into portal as "Admin" and deploying the same.

      ~Cheers,

      Vivek

  • avatar image
    Former Member
    Aug 05, 2007 at 09:44 AM

    Hi,

    
    The 500 codes mean that there is something wrong with the server. It's going to be one of:
    
    1. You haven't started your server. Check it.
    2. You server is not on port 50000. Check the configuration.
    3. An error occurred on the server. Look at the logs for an exception.
    
    

    ...If the username and password are correct heck the portno....

    check whether the server started off completely.

    Thanks

    ritu

    Add comment
    10|10000 characters needed characters exceeded

  • Aug 05, 2007 at 12:30 PM

    Hi Vivek,

    This looks like a Portal specific error. Your chances of getting help might be better in the /community [original link is broken].

    Best regards,

    Vladimir

    Add comment
    10|10000 characters needed characters exceeded