Skip to Content
0
Former Member
Jul 27, 2007 at 04:37 PM

Livecache homogenous system copy

34 Views

I am trying to restore the Livecache database from a production to a test instance

My production instance is called PL1 and test is TL1.

I am doing the following

dbmcli -d TL1 -u control,testpass db_stop

dbmcli -d TL1 -u control,testpass db_drop

dbmcli db_create TL1 control,testpass

dbmcli -d TL1 -u control,testpass medium_put

databasecopy /sapdb/backup/PL1_FULL.2006-77-25-20:17:00.10956810 FILE

DATA 0 0 NO

dbmcli -d TL1 -u control,testpass -uSRV -c recover_config databasecopy

next I am running a script that contains all parameters and volume

definitions

dbmcli -d TL1 -u control,testpass -i t

The contents of the file t are as under

param_startsession

param_put RUNDIRECTORY /sapdb/data/wrk/TL1

param_put DIAG_HISTORY_PATH /sapdb/data/wrk/TL1/DIAGHISTORY

param_checkall

param_commitsession

param_addvolume 1 DATA /sapdb/TL1/sapdata/DISK0001 F 640000

param_addvolume 2 DATA /sapdb/TL1/sapdata/DISK0002 F 640000

param_addvolume 1 LOG /sapdb/TL1/saplog/LDISK001 F 128000

param_addvolume 2 LOG /sapdb/TL1/saplog/LDISK002 F 128000

param_addvolume 1 MLOG /sapdb/TL1/saplog/M_LDISK001 F 128000

param_addvolume 1 MLOG /sapdb/TL1/saplog/M_LDISK001 F 128000

param_addvolume 2 MLOG /sapdb/TL1/saplog/M_LDISK002 F 128000

db_admin

The now I run the following command

dbmcli -d TL1 -u superdba,admin -uUTL db_activate recover completef

This command fails with

Error! Connection failed to node (local) for database TL2: ERR_USRFAIL: user authorization failed

I also tried

dbmcli -d TL1 -u control,testpass -uUTL db_activate recover completef

This also fails with following error

ERR

-24988,ERR_SQL: sql error

-4008,Unknown user name/password combination

What am I doing wrong?