Skip to Content
0
Jul 26, 2007 at 07:27 PM

R3trans cannot load dboraslib libraries

215 Views

Hi,

I have being looking for a solution on this problem but so far haven´t found anything that helps me out.

We are upgrading R3 from 4.5B to ERP 2005 SR2 so we needed to upgrade first OS to windows 2003 enterprise server and Oracle from 8.1.7 to 10g. This DB upgrade is done in two steps, first we go to 9.2.0.2 and after that we upgrade to 10.2.0.2 that is only supported for SAP upgrade purposes

DES and QAS systems worked fine using this approach after using kernel 4.5B ext and the last versions of dboraslib.dll and R3trans for the OS-DB combination.

In PRD is a totally different story, we upgraded the DB up to 9i with no problems at all (as in the first two systems) but then, after following the SAP 10g upgrade guide as we did before the system did not came up. The error, DB connection could not be stablished. So I tried the R3trans -x command but it only shows this:

4 ETW000 r3trans version 6.05 (release 45B - 21.03.07 - 11:35:00).

4 ETW000 ===============================================

4 ETW000

4 ETW000 control file:

4 ETW000 R3trans was called as follows: r3trans -d

4 ETW000 date&time : 22.07.2007 - 19:24:46

4 ETW000 trace at level 2 opened for a given file pointer

4 ETW000 Sun Jul 22 19:24:46 2007 0.000000

4 ETW000 Loading library 'dboraslib.dll' ...

4 ETW000 0.000000

4 ETW000 DlLoadLib: LoadLibrary dboraslib.dll, Error: 126

4 ETW000 765 0.000765

4 ETW000 *** ERROR => Couldn't load library 'dboraslib.dll'

4 ETW000 35 0.000800

2EETW169 no connect possible: "connect failed with DBLI_RC_LOAD_LIB_FAILED."

I have being looking for notes, over the net, triple checked enviroment variables but nothing seems to work, then I tried something different, I copied dboraslib.dll used for kernel 7 and paste it over the 4.5B ext kernel and then R3trans is able to load the libraries but off course, it shows and error about the kernel version.

This last test make me thing that there is no problem at the enviroment level but the dboraslib.dll we are using was downloaded from marketplace and it is supposed to be the last one and it should work fine with Oracle 10g.

What are your thoughts about this.