Skip to Content

ADRMAS03 Inbound IDoc from PI to SAP FI - Missing entry in TSADOBJ

Aug 02, 2017 at 01:18 PM


avatar image

Hi all!

I try to import a idoc from our SAP PI to our SAP FI. The idoc is of type ADRMAS03 and the system always reacts with "No appropriate entry found in table TSADOBJ". I've tried to add several entries in the table, but nothing worked out.

Any clues? How to I have to edit the table and what entries have to exist for ADRMAS03?

Best regards


10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Patrick Weber Aug 02, 2017 at 02:41 PM

Hi Matthias,

I'm not overly familiar with this IDoc type and the exact processing will depend on the type of address you're sending but I believe on a high level it works like this:

Table TSAOBJ is read according to the following scheme:

OBJTYPE: The Canonical name of your business object (e.g. BUS1006 for a business partner)

ADDRTYPE: The type of address you're maintaining
1 Organization, Company
2 Private address
3 Contact person (in company)

0001 Main address of a Company/Organization
0002 Different business address
0003 Private address (with company address structure)
0004 Private address (with person address structure)
0005 Compiled business address
0006 Delivery address per order item
0007 Communication Data Without Postal Address

Return values:
TABLENAME: The name of the table that you're updating the address for (e.g. BUT000 for business partner)
FIELDNAME: The name of the field containing the key (e.g. PARNTER for BUT000)

Based on the table name and field name, the system will then look up the function and parameters to access the actual address in table TSADRV.

You can set a breakpoint in FM ADDR_TSADOBJ_READ_SINGLE to see what values are being used for the query in your case and follow along the subsequent processing steps.

I know this is probably not the easy that you were hoping for but while there's no better answer, I hope it can provide you a pointer to move forward.


10 |10000 characters needed characters left characters exceeded
Matthias Carstens Aug 03, 2017 at 08:12 AM

Hi Patrick,

thank you very much for your reply. I've found a solution!

Actually the fields in the PI weren't filled correctly. I changed this according to your Information and it works. Before that I debugged the inbound Interface. In my case the function ADDR_TSADOBJ_READ_INVERSE is used, not *SINGLE. Because the process is triggered by the PI my user isn't part of the process and just setting a breakpoint in the function didn't worked. I had look up the IDoc number via WE02 and after that I could restart the process via BD87.



Show 1 Share
10 |10000 characters needed characters left characters exceeded

Glad this helped. Have a good day!