Skip to Content

Solution Manager 7.2: TREX initial indexing takes very long time

Aug 01, 2017 at 01:07 PM


avatar image

Hi all,

Our client wants to use Embended search for their 7.2 solman. They have a good amount of solution documentation stored in the system. We have TREX with 7.10 P56 installed and configured. RFC,ICM connections are working fine.

When calling ESH_COCKPIT and starting initial indexing for "Solution Documentation: KW Info Object" after a time it seems the process is stucked. At least we do not see any progress there. Re-executed initial indexing several times and we have the same result, at 719403 objects it stops. Where the other one "Solution Documentaion: Element" is already indexed correctly with the same initial load.

In ABAP we can see the program running with state waiting for RFC response, probably waiting for the TREX to tell if he is ready with the indexing.

Anybody had the same already or any ideas where i can follow the process in more detail?

01.png (62.4 kB)
02.png (9.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Krisztian Lazar Aug 16, 2017 at 01:09 PM


Thanks it was implemented.

However the solution is different.

After contacting SAP we had to upgrade the TREX to latest patch, this solved the issue we had.

And also the following notes helped to optimize the performance:

2344042 - How to execute python script

2227741 -TREX settings for the Enterprise/embedded Search scenario



10 |10000 characters needed characters left characters exceeded
Deepak Nemani Aug 02, 2017 at 09:45 AM


Check if you have implemented this Note

2115082 - ESH Index Preload



10 |10000 characters needed characters left characters exceeded