Skip to Content
avatar image
Former Member

NWDI template Insaller Error

Hi,

I am running a Template Instaler for NWDI but it can't continue to to the error in Create Software Component Phase:

Element 'SAPConfigLib.SR1.Unclassified.pingSld':!BrokerImport.import_of_element_failed!!BrokerImport.Fehler!com.sap.tc.lm.ctc.cul.cpi.exceptions.CPIBaseException: < Localization failed: ResourceBundle='com.sap.tc.lm.ctc.cul.cpi.CPIResourceBundle', ID='com.sap.tc.lm.ctc.cul.cpi.BaseException_BASE_EXCEPTION', Arguments: [] > : Can't find resource for bundle java.util.PropertyResourceBundle, key com.sap.tc.lm.ctc.cul.cpi.BaseException_BASE_EXCEPTION:com.sap.tc.lm.ctc.provider.javaServiceProvider.JavaServiceWriter.writeElement!BrokerImport.LINE!157-:com.sap.tc.lm.ctc.cul.broker.BrokerImport.importElement.86

-:com.sap.tc.lm.ctc.cul.broker.BrokerImport.importElement.128

-:com.sap.tc.lm.ctc.cul.broker.BrokerImport.importElement.128

-:com.sap.tc.lm.ctc.cul.serviceimpl.importservice.CULConfigurationImport.importConfiguration.96

-:com.sap.tc.lm.ctc.ccl.templateinstaller.StepExecuter.run.41

Element 'SAPConfigLib.SR1.Unclassified.pingSld':Error during executing Java Reflection:CIM_ERR_FAILED: User credentials are invalid or user is denied access

How to resolve that? Please help Thanks.

Jennah

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

7 Answers

  • avatar image
    Former Member
    Jul 26, 2007 at 09:35 AM

    Hi,

    I have also this error at Import Build Plugin phase

    Element 'SAPConfigLib.SR1.Unclassified.configureCms':!BrokerImport.import_of_element_failed!!BrokerImport.Fehler!com.sap.tc.lm.ctc.cul.cpi.exceptions.CPIBaseException: < Localization failed: ResourceBundle='com.sap.tc.lm.ctc.cul.cpi.CPIResourceBundle', ID='com.sap.tc.lm.ctc.cul.cpi.BaseException_BASE_EXCEPTION', Arguments: [] > : Can't find resource for bundle java.util.PropertyResourceBundle, key com.sap.tc.lm.ctc.cul.cpi.BaseException_BASE_EXCEPTION:com.sap.tc.lm.ctc.provider.javaServiceProvider.JavaServiceWriter.writeElement!BrokerImport.LINE!157-:com.sap.tc.lm.ctc.cul.broker.BrokerImport.importElement.86

    -:com.sap.tc.lm.ctc.cul.broker.BrokerImport.importElement.128

    -:com.sap.tc.lm.ctc.cul.broker.BrokerImport.importElement.128

    -:com.sap.tc.lm.ctc.cul.serviceimpl.importservice.CULConfigurationImport.importConfiguration.96

    -:com.sap.tc.lm.ctc.ccl.templateinstaller.StepExecuter.run.41

    Element 'SAPConfigLib.SR1.Unclassified.configureCms':Error during executing Java Reflection:Version conflict: to call method 'checkInHighestVersionSCAs' the minimum server version is 'Release 6.40 SP12 Patch level 00' but the used server has only version 'Release 6.30 SP07 Patch level 00 or less'

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jennah,

      I am also getting the version conflict issue. Were you able to resolve this issue? Can you please help me resolving this issue.

      Thanks in Advance.

      Regards,

      Vasu Pabbaraju.

  • avatar image
    Former Member
    Jul 25, 2007 at 04:20 AM

    Hrllo Jennah ,

    Please specify the user who have access of SLD .

    You are getting the error while accessing SLD ( Element 'SAPConfigLib.SR1.Unclassified.pingSld':Error during executing Java Reflection:CIM_ERR_FAILED: User credentials are invalid or user is denied access)

    Regards ,

    Santosh Karadkar

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 26, 2007 at 01:48 AM

    Hi All,

    Any updates on this please? I can't proceed with the template installer because Import is not successful at phase Create Softwware Component. And as stated above, I get such error.

    Thanks,

    Jennah

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi ,

      The issue is because your user with which you are trying to import does not have the LcrClassWriter role.

      Please assign this role to the user with whihc you are trying to install I advise that you give the LcrAdministrator role.

      Check whether there is a role called LCRAdministrator in your system. If it is not there proceed as below.

      Login to http://server:port/useradmin

      Create a UME Role LcrAdministrator and assign UME action sap.com_com.sap.lcr.LcrAdministrator to this role.

      Create a UME role SAP_SLD_ADMINISTRATOR and assign the role LcrAdministrator to this group.

      Assign your user to this group.

      You can also assign the role LcrAdministrator directly without creating a group to the user id with which you are trying to import CIM content.

      Let me know the result.

      Thanks & Regards,

      Vijith

  • avatar image
    Former Member
    Jul 26, 2007 at 08:59 AM

    Hi Vijith,

    I have already made my user with such administrator roles as you have stated . Still I got the error. In the template installer, the users were J2ee_admin, Nwdi_cmsadm, nwdi_adm and nwdi_dev. The user I gave admin role was nwdi_cmsadm because it is the user who access SLD dor DI. Am I right? what might be the problem?

    Do you know where to find this? Maybe we have to solve this?

    Element 'SAPConfigLib.SR1.Unclassified.pingSld'

    Thanks,

    jennah

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jennah,

      I am really not sure on the issue 'SAPConfigLib.SR1.Unclassified.pingSld'.

      Can you have a look at the note 939892. The note points to a very similar error that you got but the installation was a different template.

      Try whether you can corelate. Do update if you get a solution

      Thanks & Regards,

      Vijith

  • avatar image
    Former Member
    Jul 26, 2007 at 09:29 AM

    Thanks Vijith. Yes we might have similar error most especially on the first error. The note says manual configuration must be done. But I guess it is only for PI. Because in our EP 7.0 system, we were able to execute the DI template installer successfully, but why is not successful now? Are there any solutions to this?

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 21, 2007 at 12:33 AM

    Hi Vasu,

    Unfortunately I did not continue the installation. But I can help you with some advice. Are you doing a fresh installation of the system? Is your SLD already configured? Can you give me a brief overview of the installation as well as the version of your DI?

    Thanks,

    Jennah

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jennah,

      Thanks a lot for the reply.

      Yes I am doing a fresh installation of usage type DI.

      Here is the landscape details.

      1. We have installed a NW04S Portal on a windows 2003 server. This server is configured as the central SLD. Version is NW04S 7.0 SP08.

      2. Usage type DI installed on a different server. This server is configured to talk to central SLD on the portal server. Version is NW04S 7.0 SP09.

      what I guess is when we are configuring SP09 to talk to SP08 SLD it is throwing errors due to version conflict.

      Am I guessing right?

      Will wait for you advice.

      Thanks and Regrads,

      Vasu Pabbaraju.

  • avatar image
    Former Member
    Aug 22, 2007 at 03:41 AM

    Hi Vasu,

    Can I get all the errors you have encountered? Are you also doing a post installation of the DI using the template installer? Please provide me the exact error. Thanks.

    Regards,

    Jennah

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Jennah,

      As I told you my central SLD server is running on a lower version than the NWDI Server. When I switched central SLD server to a instance which is on SP11 my version conflict issue while executing DI Template Installer got resolved.

      Now I am facing an issue while Importing Build Tools SCA into the Demo Track. I am getting request timed out exception. ( This is the last step in the DI Template Installer)

      Although Template Installer progress shows 100%, when I go to CMS Transport Editor all the Build too SCA imports are failed.

      Any Ideas?

      Your help on this is greatly appreciated.

      Thanks nad Regards,

      Vasu Pabbaraju.