Skip to Content
avatar image
Former Member

Does Crystal Reports 2011 only work with MS Visual C++ 2005?

Does Crystal Reports 2011 ONLY work with MS Visual C++ 2005 and/or the

MS Visual2005 C++ Security update? I know about the

https://apps.support.sap.com/sap/support/knowledge/public/en/1689645 link, but I don't know when that knowledge base was created and if it was created before any other more recent MS Visual C++ versions were available. I understand we could follow that and install 2005, but according to our organization that product is considered End of Life. We recently removed 2005 on one of our servers, but have 2008 and 2010 on the server and are now getting the "The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail." error. I want to make sure CR2011 isn't compatible with newer versions of C++

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Jul 27, 2017 at 08:20 PM

    CR 2011 needs 2005 C++ libraries and their security updates.

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 27, 2017 at 08:22 PM

    Both of those versions of CR still require that VS 2005 C++ ATL Security update.

    To no longer require it you need to go to CR 2016 SP 4, but be aware some third party dependencies still need that runtime.

    So leave it on your PC's for now...

    Don

    Add comment
    10|10000 characters needed characters exceeded