Skip to Content
avatar image
Former Member

SAP gateway and disp+work died after a view seconds

Dear Forum,

2 additional instances have just installed for a GTS on NW04S. Located on other servers than the CI.

When I started, everything was running, then died. The shortest process was the gateway, only alive for 15 seconds then died...., followed by all disp+work.

In the dev_rd:

================

-


trc file: "dev_rd", trc level: 1, release: "700"

-


Tue Jul 24 06:25:26 2007

***LOG S00=> GwInitReader, gateway started ( 6140) [gwxxrd.c 1693]

systemid 562 (PC with Windows NT)

relno 7000

patchlevel 0

patchno 94

intno 20050900

make: multithreaded, Unicode, 64 bit, optimized

pid 6140

gateway runs with dp version 224000(ext=109000) (@(#) DPLIB-INT-VERSION-224000-UC)

gw/local_addr : 0.0.0.0

CCMS: AlInitGlobals : alert/use_sema_lock = TRUE.

Bind service sapgw00 (socket) to port 3300

Bind service sapgw00s (socket/snc) to port 4800

GwPrintMyHostAddr: my host addresses are :

1 : [192.168.188.157] GDCS032P.erp.gdc.com (HOSTNAME)

2 : [127.0.0.1] GDCS032P.erp.gdc.com (LOCALHOST)

3 : [10.200.3.157] gdc032pb (NILIST)

4 : [192.168.187.157] GDCS032P.erp.gdc.com (NILIST)

DpSysAdmExtCreate: ABAP is active

DpSysAdmExtCreate: VMC (JAVA VM in WP) is not active

Tue Jul 24 06:25:27 2007

DpShMCreate: sizeof(wp_adm) 63296 (1472)

DpShMCreate: sizeof(tm_adm) 55595792 (27784)

DpShMCreate: sizeof(wp_ca_adm) 80000 (80)

DpShMCreate: sizeof(appc_ca_adm) 160000 (80)

DpCommTableSize: max/headSize/ftSize/tableSize=2000/16/2208064/2208080

DpShMCreate: sizeof(comm_adm) 2208080 (1088)

DpSlockTableSize: max/headSize/ftSize/fiSize/tableSize=0/0/0/0/0

DpShMCreate: sizeof(slock_adm) 0 (104)

DpFileTableSize: max/headSize/ftSize/tableSize=0/0/0/0

DpShMCreate: sizeof(file_adm) 0 (72)

DpShMCreate: sizeof(vmc_adm) 0 (1848)

DpShMCreate: sizeof(wall_adm) (416064/346352/64/192)

DpShMCreate: sizeof(gw_adm) 48

DpShMCreate: SHM_DP_ADM_KEY (addr: 000000000D6D0050, size: 58877856)

DpShMCreate: allocated sys_adm at 000000000D6D0050

DpShMCreate: allocated wp_adm at 000000000D6D1F40

DpShMCreate: allocated tm_adm_list at 000000000D6E1680

DpShMCreate: allocated tm_adm at 000000000D6E16E0

DpShMCreate: allocated appc_ca_adm at 0000000010BFA270

DpShMCreate: allocated comm_adm at 0000000010C21370

DpShMCreate: system runs without slock table

DpShMCreate: system runs without file table

DpShMCreate: allocated vmc_adm_list at 0000000010E3C4C0

DpShMCreate: allocated gw_adm at 0000000010E3C540

DpShMCreate: system runs without vmc_adm

DpShMCreate: allocated ca_info at 0000000010E3C570

MtxInit: -2 0 0

Tue Jul 24 06:25:33 2007

GwDpInit: attached to gw_adm at 0000000010E3C540

Tue Jul 24 06:25:43 2007

***LOG S30=> GwStopGateway, gateway stopped () [gwxxrd.c 14147]

================

I can see in the dev trace of dispatcher and others, everything was initialized properly, then suddenly got a signal for shuting down.

For example in dev_disp:

================

Tue Jul 24 06:25:36 2007

MBUF state ACTIVE

  • ERROR => DpRqNoWpHandle: SHUTDOWN request from wp_id 18 received [dpxxdisp.c 5092]

DpHalt: shutdown server >gdcs032p_GP1_00 < (normal)

DpModState: change server state from STARTING to SHUTDOWN

Stop work processes

================

Then all disp+work were dying ...

When I looked at the syslog in MMC, the only suspicious message is a warning: "SAP-Basis System: There is an Error in the Enqueue Configuration".

FYI, it is a clustered system. But, I have another clustered system on NW04 works properly, as well its additional instances.

Please help.

Regards,

Agoes

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Jul 24, 2007 at 09:19 AM

    Found the problem. There was an enq defined in the instances. So, I remarked it in the profile parameter, since there is only an enq allowed in the system.

    Regards,

    Agoes

    Add comment
    10|10000 characters needed characters exceeded