Skip to Content
0

PD does not allow to select NSM file for Table Name abbreviations in PDM

Jul 26, 2017 at 04:22 PM

55

avatar image
Former Member

hi

I am using PD 16.5 SP03 PL03 version.

While I am in the physical model, I could select the NSM file for Columns:

right click on model -> select Model Options -> Naming Conventions -> Column -> on the right panel click the tab 'Name to Code' then I click on the folder icon and select the NSM file that I can use for Column names.

I also want to use another NSM file exclusively for table name abbreviations. If I follow the same path for table, PD doesnot allow me to click on the folder path and select the NSM file for table name abbreviations. I was able to do this in a different PDM file.

I don't understand why I was able to do it one file and not in another file.

10 |10000 characters needed characters left characters exceeded

I can't see why this should be any different for Tables. What version of PD are you using, and do your PDMs have the same DBMS?

0
Former Member

PD 16.5 SP03 PL03

I have checked the dbms on both PDMs, they are identical. I am surprised as to why I can't click on the folder icon and select NSM file for table names only in one PDM where as it allows me to do it from another PDM. I am sure there must be some kind of configuration difference somewhere.
0

Is the fautly model checked-out from the repository as read-only (perhaps you don't have Write or Full permissions on it)?

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Matt Creason
Jul 28, 2017 at 05:08 PM
0

Make sure that you have not set the high-level NSM file at the Naming Convention root, otherwise it could have a trickle down effect. Otherwise see George's note on making sure you did not check it out as Read-Only, as that also sets the Windows Read-Only flag.

Br,

-Matt C.

Share
10 |10000 characters needed characters left characters exceeded