Skip to Content
0

SAP EWM process order with backflush not working

Jul 30, 2017 at 08:21 PM

843

avatar image
Former Member

Hi experts,

My system is EWM 9.4.

Step 1: Create a process order in COR1 with backflush indicator checked

Step 2: Release and stage the process order in ECC

Step 3: Create EGR document in ECC

Step 4: Stage the components in EWM and Warehouse tasks created and confirmed

Step 5: Perform goods receipt in EWM via RF device with the HU option

Step 6: The 101 document gets posted into ECC w.r.t the order.

Step 7: No automatic goods issue of components happen in ECC.

Please help if you find any system config/master data missing

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

6 Answers

Serhan Er Jul 31, 2017 at 12:24 PM
0

Hi,

Can you try this on a non-EWM storage location and see if it posts goods issue automatically? If not, the problem is caused by IM-PP interface and we cannot help you in this EWM section.

Best regards

Serhan

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Jul 31, 2017 at 06:20 PM
0

Yes, it work perfectly for IM and even for WM locations. The only time it fails to create is the moment we enter the EWM Sloc

Share
10 |10000 characters needed characters left characters exceeded
Ajit Routray Aug 01, 2017 at 03:54 AM
0

Hi Jyotirindra,

Are you using PMR or Delivery Based Production Supply ?

PMR->"When a material is set as backflush item in the manufacturing order, you cannot enter the goods issue in SAP EWM.

When you enter a backflush in SAP ERP, SAP ERP creates a consumption posting delivery, as described in consumption for delivery-based production supply. You can configure the system so that it adds the goods issue document to the respective PMR item as well as to the consumption posting delivery. You can use this functionality to have the same information for all items in the PMR.

You cannot use single-order staging for a material set as backflush item"

Please check this Reference: Production Integration Types and let us know if you still facing issues.

Kind Regards,

Ajit

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Aug 01, 2017 at 12:20 PM
0

Hi Ajit,

Thanks a lot for your advice. I followed your document and validated against each one of my settings in ECC and EWM. You can configure the system so that it adds the goods issue document to the respective PMR item as well as to the consumption posting delivery. The problem is, I'm not able to create the Consumption posting delivery in ECC for the backflushed order. Is there any Program/PPF/Profile I'm missing?

Kind Regards,

JG

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi JG,

-> Are you able to create Consumption posting delivery manually in MIGO ( Goods Issue - Order then your Process Order ) ?

-> Check Tcode COGI , Are you getting any items in this tcode ?

Kind Regards,

Ajit

0
avatar image
Former Member Aug 01, 2017 at 02:12 PM
0

Hi Ajit,

No, I'm getting the message "Document XXXXXXXXX does not contain any selectable items in MIGO" with the backflushed Process order. Without backflush I'm getting everything in MIGO. Even in COGI, it says, "No record was found" for that Process Order.

Kind Regards,

JG

Show 8 Share
10 |10000 characters needed characters left characters exceeded

Hi JG,

Please check those points below .

"No, I'm getting the message "Document XXXXXXXXX does not contain any selectable items in MIGO" with the backflushed Process order." -Right.

"Without backflush I'm getting everything in MIGO" 1- Are you getting outbound Delivery or Material document of 261 for GI ? ( I mean only for goods Issue )

->If you are able to post directly Material document of 261 in MIGO, then WM Movement type setting missing for 261 for your Warehouse( Logistics Execution->Decentralized WMS Integration->Central Processing->Application->Define Interface to Inventory Management and Delivery-Relevant Data and Extended Warehouse Management Integration->Production Planning and Control->Define Delivery Type Determination )

"Even in COGI, it says, "No record was found" for that Process Order." -It means 261 Material document posted for that process order If you tried with confirmation ? Please check MB51.

Also Please try manual confirmation with Tcode COR6N ( Process order confirmation ) and check Goods movement Tab for GR and GI.

Kind Regards,

Ajit

0
Former Member
Ajit Routray

Hi Ajit,

The backflush in CORK works perfectly for IM and WM locations.The moment I provide the EWM SLOC and it's supply area, the automatic backflush stops. I tried all possible settings in ECC , but the Consumption posting delivery is not getting created in ECC and hence the goods issue during backflush connected to EWM is not happening. I'm providing below the screenshots of the delivery type maintained in each system.

SAP EWM Integration--Outbound Process--Direct Outbound Deliveries--Determine Delivery Types for Direct Outbound Deliveries

EWM Delivery Type is "OPC" and ECC Delivery type is "DOG"

SAP EWM Integration--Outbound Process--Direct Outbound Deliveries--Determine Item Categories for Direct Outbound Deliveries

EWM Delivery Type is "OPC" and EWM Item Type is "ODPC"

Still not able to create the consumption posting delivery in ECC

0

Hi Jyoti,

"Consumption posting delivery is not getting created in ECC"

Please provide some info.

Did you maintain below settings in ECC?

1> Logistics Execution->Decentralized WMS Integration->Central Processing->Application->Define Interface to Inventory Management and Delivery-Relevant Data->Delivery-Relevant Data for Warehouse Number

Ship-to party( Internal - Outbound ) ,Vendor ( Internal- Inbound ) ,Shipping Point ,Sales Organization, Distribution Channel ,Division for your warehouse which has assigned to EWM Storage location.

2> Materials Management->Purchasing->Purchase Order->Set up Stock Transport Order->Define Shipping Data for Plants

Please first check with MIGO ( Goods Issue manually W/O backflush ) , If it works fine ( Means Outbound delivery created ) ,If not works,Please share the error screen shot .

Once the above is successful then test in confirmation through tcode COR6N with backflush .

Kind Regards,

Ajit

0
Former Member

Hi Ajit,

I did exactly the way you said.

W/O Backflush, it created a consumption posting delivery out of ECC after MIGO posting. It went to EWM and posted the GI automatically, but nothing came back to ECC

W Backflush

In MIGO, : "Document XXXXXXXXX does not contain any selectable items in MIGO"

In COGI, , "No record was found"

In COR6N, : It says, Consumption posted, but without any material document postings. No 261 document generated.

So, in short, it is the same behaviour I was experiencing before too.

0

Hi Jyotirindra,

Thank you for details.

"W/O Backflush, it created a consumption posting delivery out of ECC after MIGO posting. It went to EWM and posted the GI automatically, but nothing came back to ECC"

It seems GI docs stuck in Queue( Either in ECC or EWM ).Please check the steps below to get back the GI doc from EWM to ECC.

1> Check PPF trigger from EWM after GI ( Tcode /SCWM/PRDO->Check Outbound delivery order status, then select the line click on Outbound delivery button ,then Outbound delivery check the PPF Tab ( This will send the GI doc to ECC from EWM i.e, the Material document of 261 so that system will update those in delivery as well as in Manufacturing order ).

2> Check the Outbound queue in EWM ( Tcode SMQ1 )

3> Check the Inbound Queue in ECC ( Tcode SMQ2 )

Note: Either you double click on the error to find details or you can try Tcode SLG1 in both system if Queue stuck.

W Backflush

"In MIGO, : "Document XXXXXXXXX does not contain any selectable items in MIGO"" This is the rightly standard behavior.

"In COGI, , "No record was found"" This is fine.

"In COR6N, : It says, Consumption posted, but without any material document postings. No 261 document generated."If the manual delivery is sort out , then there will be now problem for 261 doc.Please check the above steps for manual and find out where and why it stuck and share the screen shot if possible.Check Tcode CORT , enter process order , click good movement button , you will find IN( 101 )+OUT( 261)bound delivery.

"So, in short, it is the same behaviour I was experiencing before too." Sorry,I understand now,I thought you are not able to create the delivery in ECC for GI ( consumption ) as per your earlier message.

Please check this link for your consumption scenario.Special case of GI and Consumption Posting Delivery for Production Supply

Please check and let know us know your findings in above.

Kind Regards,

Ajit

0
Former Member

Hi Ajit,

W/O Backflush

It's stuck in the ECC inbound queue as "Update control of movement type is incorrect (261 X X --- V). I maintained it, but still same error

W Backflush

It's the same issue, not getting posted

0

Hi Jyotirindra,

"W/O Backflush

It's stuck in the ECC inbound queue as "Update control of movement type is incorrect (261 X X --- V). I maintained it, but still same error" -> Strange.I doubt Its wrong account posting ,sorry but I am not sure ( not aware of your business ).Please check Material Type.....etc related to posting.Please check for OSS note or raise an OSS Incident message to SAP .

Kind Regards,

Ajit

0
Former Member

Hi Ajit,

I tried a different thing today with backflush. I created a receipt in an IM location and issue in EWM location. Did a CORK, and the system generated a message that 2 deliveries created. I could not find the deliveries in ECC, neither in the queue. Then I searched the COGI and found that it's lying there with "Essential transfer parameters are missing in record: 000002". This might be the reason? Any idea Sir

Regards,

JG

0
avatar image
Former Member Apr 12 at 04:18 PM
0

Hi Jyotirindra

Did you find any suitable solution? We are facing same issue with no backflush execution in ECC after EWM GR

Share
10 |10000 characters needed characters left characters exceeded