Skip to Content
avatar image
Former Member

SAP UI5 library version

We are upgrading SAP_UI component from 740 to 750 and this will take us from SAP UI5 1.28 to 1.38

Is there a way to retain the older version or port back an older version of SAP UI5 library on top of the latest?

Reason behind is that we have a custom UI5 application that uses 1.28 function and is deprecated in 1.38

Thanks in Advance!

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Jul 27, 2017 at 05:24 AM

    You could directly use the 1.28 version of JS library in the index.html. So instead of referring to the default UI5 in the upgraded server, refer to the 1.28 version of UI5 JS library.

    Check the following thread, which discusses a similar issue:

    https://archive.sap.com/discussions/thread/3845580

    Regards,

    Sharath

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 27, 2017 at 10:47 AM

    Yes you can use 1.28 after upgrade.

    change library path from /resources/sap-ui-core.js to 1.28/resources/sap-ui-core.js in your application

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 27, 2017 at 02:26 PM

    Thanks for your feedback @ Sharath and Abdul.

    Yes, we can specify the library path to an older version of UI5. The question is whether, the older version of UI5 library will be there after upgrading SAP_UI to 750 or do we need add the older 1.28 version back? And how?

    Add comment
    10|10000 characters needed characters exceeded